Dvd/rw driver problems not in the device [Solved/Closed]

- Nov 2, 2008 at 05:23 PM - Latest reply:  faz
- Sep 15, 2014 at 05:29 AM
Hello,
I am having problems the dvd/rw driver and it won't show on the device and my computer and it is missing and that I have done on F2 and found the driver dvd/rw and it said (Not Present) but how to change it without (Not Present) from Dell Bios F2.
Please can you help me...

Regards John.
See more 

40 replies

Best answer
Posts
165
Registration date
Tuesday September 30, 2008
Last seen
February 3, 2009
- Nov 2, 2008 at 07:22 PM
7
Thank you
To resolve this behavior, follow these steps:


1.Start Registry Editor (Regedt32.exe).

This can be done by opening the start menu and left clicking RUN, another option is pressing the windows logo key on the keyboard

together with the R key, in the box you type regedit and click OK ( or enter on your keyboard )
2. Find the right key in the registry.

Locate the UpperFilters value under the following key in the registry:

HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > Control > Class > {4D36E965-E325-11CE-BFC1-08002BE10318}

When you see the UpperFilters key left click it and press delete, you will be asked for a confirmation, just click YES

Now do the exact same but with the Lowerfilters.
3. Reboot the computer

Now restart your computer and you should have a working CD/DVD drive once more !

CONCLUSION:

Some CD/DVD writing software change the filters in the registry to there own, this can sometimes cause problems.

By deleting these value's windows puts them back on default after a reboot.............Good Luck!!!!!!!

Thank you, rubrami281 7

Something to say? Add comment

CCM has helped 1667 users this month

Tried deleteing upper and lower filters in regedit and rebooting the machine.
Still didn't solve my problem.
Oliver, download the free version of System Mechanic by IOLO. Then run their registry cleaner. This solved my problem. Hope it will solve yours. I commented above back in February 15.
Thank you very much for this fix. It did the trick on my system.
hi
I found lowerfilters but I cannot find the upperfilters...
wher are they?
Computer - Dell E5500 Laptop

CD/DVD recognised and functioning in computer BIOS, but not in Windows.
Missing in device manager, could not be found in new hardware set-up.
Found this information, and worked!!!

No upper filter found in
HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > Control > Class > {4D36E965-E325-11CE-BFC1-08002BE10318} , only a lower filter.
Deleted the lower filter (as the upper was missing anyway) and re-started the computer.
No CD/DVD in My Computer, so went into device manager - found CD/DVD (not enabled)
Enabled DC/DVD drive, closed device manager.
Went back into My Computer to find DVD Drive - THIS WORKED LIKE A TREAT!!!!!!!
Best answer
7
Thank you
This same thing happened on my Gateway Laptop MT6709 running Vista and none of the methods above worked.

Gateway suggested the following and it worked first time around - thought I would pass it along. both music cds and dvd's came right up and all sound was normal

1. Click on Start and then Control Panel.
2. Click on the button in the upper left hand corner labeled "Switch to Classic View"
3. Double Click on System
4. In System, click on the Hardware Tab.
5. In the Hardware Tab, click on Device Manager.
6. In the Device Manager, double click on "DVD/CD-ROM Drives"
7. Double click on what appears below "DVD/CD-ROM Drives".
8. In the Device Properties box, click on the Driver Tab
9. In the Driver Tab, click on Uninstall Driver
10. Shutdown and restart the computer.

Thank you, Rabbett 7

Something to say? Add comment

CCM has helped 1667 users this month

0
Thank you
Thank you so much! You guys are awesome. That answer saved me so much time and ripping my hair out. :-D
0
Thank you
hiya

All working thank you. Used the windows support app. On Windows7 I had to troubleshoot the device and then troubleshoot the audio to get the cd-dvd issue resolved. thanks for the advise.
0
Thank you
it's work. thank you very much
0
Thank you
very good one..thank you folks