How get Creative Webcam Live! work in W-Vista

Solved/Closed
PD2000 - Nov 28, 2008 at 11:59 PM
 hungover - Jul 8, 2013 at 04:21 PM
This how you get your Creative Webcam Live! working in Windows Vista.

1)Go to cd rom Drive where your Cd is highlight it click right mouse explore cd.
2)Highlight the Demo shield muti CD Launch Install Shield. Right click mouse open
Properties
3)Go to Campatibility.
4)click on [Run] Windows sever 2003 (Serivce pack 1) then hit apply close it
5)Double click Demo shield muti CD Launch Install Shield it should load then click next
to install.
6)this should solve lot people problems with there webcam Cd drivers working in Windows Vista.

13 replies

Thank you.. thank you.. you are brilliant which in turn made me look brilliant...

Happy New Year..

Cyn
0
Excellent. Thanks very much for posting this!
0
I tried exactly that, but it tells me that an error occured while setting up the driver. I have a dual-core x64 AMD Vista and the driver doesn't seem to be compatible with x64!

Any ideas?
0
Hope someone already helped you - I also have AMD 64 and the method works perfectly. The only problem is to find Demo 32 Instal Shield - also you need "normally" restart CD but then it will install perfectly.
0
i have the same problem, but I dont have the CD anymore....
0
AMAZING!!! It really works! Great trick - thank you :D
0

Didn't find the answer you are looking for?

Ask a question
*The Unpredictable*
Jul 8, 2009 at 07:40 PM
THANKS I OW U ! I installed Windows 7 but my webcam suports only XP so your solution works prety well I tested on games 2 !!!
0
wow thanks for this I was about to spend £60 on a new cam tommorrow I downloaded the 64bit and installed it and it worked a treat thanks guys
i have windows vista 64bit ultimate and it worked perfect :)
0
Any windows & driver for Creative WebCam Live|Pro?
0
I tried the advice to get my Creative Live! Camera working on my version of Vista (32 bit) and it didn't work. Install program locked up after I reset the configuration to the Service Pack that you instructed to do.
Any other "solutions" suggestions would be great if they are out there.
I guess I will call Creative and see what they tell me.

Sam
0
Software installed but cam still looks for driver :( and software doesnt find the cam HELP
0
I am using Windows 7 X64 and this driver worked fine without turning on compatibility mode.

https://support.creative.com/downloads/download.aspx?nDownloadId=9241
0
Victim......what did you have to do to get it to install properly? I downloaded the driver and installed it without any luck. The installer unpacked the files without any issue, but Windows 7 64Bit could still not identify the drivers.
0
patch > Dezman
Jan 12, 2010 at 02:56 PM
well...you must go to device manager...and install the driver manually..i did so...and it worked.. :D

just point to the extracted folder
0
wtftrieditall
Nov 14, 2012 at 12:16 PM
This guy is full of it.. I do IT, and none of the creative drivers work, no MATTER WHAT, I've tried every single way possible and every Live! webcam driver, even the hidden windows 7 creative drivers page and Windows 8 beta driver page on the official site. None of the drivers work if you download them. It seems the disk may work if you still have it, according to the few people above, but I dont have it, and am now SOL (stuck like chuck) with no webcam because I upgraded my windows past WinXP. Believe me, I tried it all and have a degree in computer science so I know what I am talking about.
0
ive just tried the link too

https://support.creative.com/downloads/download.aspx?nDownloa­dId=9241

doesnt work for me either windows 7 64 bit ultimate.
0
worked under Win 7 32bit (I did the 'compatibility' thing (compatibility for Win 7) in 'properties' before installing. Thank you!
0
any time I us my cam I cant cause faces come up al the time and its doing my head in please help .. emial me 2 help lilorocks@hotmail.co.uk thanks
0
Eaglezero6205
Aug 29, 2010 at 03:49 PM
I went to the Creative website and downloaded the latest driver but when I try to run the driver I downloaded from the website It starts and runs unpacks and then it says Error and makes me close the install. I tried to Update the driver manually through Device Manager and I went to add new device but it wont even sense their is a new device. And when I plug in the camera it Makes the deive noise twice in quick rhythm like it senses and then doesn't want to. My cam is in good condition I have the driver disk still and I payed alot for this cam a while back any help would be appreciated.
0
Ambucias Posts 47357 Registration date Monday February 1, 2010 Status Moderator Last seen September 1, 2021 11,234
Aug 29, 2010 at 04:10 PM
Hello,

Some devices don't need to be upgraded or they go haywire. I suggest that you remove all drivers and reinstall the original.

Regards
0
Eaglezero6205
Aug 29, 2010 at 04:58 PM
I completely installed the programs and now I reinstalled Unsing COmpatibility Windows Server service pack 3 and I got to the Device and it say the drivers are not instlled even though I jsut Installed them I search Auto and manually for my drivers while disk is in and nothing I search manually for the update I downloaded and nothing.
0