Photoshop CS3 can't open files

Registration date
Tuesday January 8, 2008
Last seen
March 7, 2008
 ChandrashekharPatra -
Hi everyone!

I'm pretty new to this kind of site and forum and in desperate need of help...

I edit images in Photoshop CS3, until last night every function performed beautifully... Here is my problem, step by step:

I launch Photoshop CS3 successfully
I click "File"
I then click "Open"

The open windows pops up for a sec but then immediately closes! I don't even have time to see my files in the window, and of course to select anything!)

The Photoshop CS3 title bar then "mutes" and I can't make it active again
and just have to shut down Photoshop and restart it again.

The weird thing is that the other commands (New, Browse, etc.) work properly!

I'm a graphist designer and I'm used to work with Photoshop a lot, so this is a very serious issue for me. If there's anyone out there who can keep me from becoming really crazy with this issue, I would really appreciate.


57 replies

I had a co-worker with this problem and it was solved by doing this:

-press ESC after attempting to open a file
-pressing CTRL+SHIFT+S (save-as) supposedly resizes the window to it's default size.

Let me know if that works or not. This is just what I heard.
Yes, it worked!!!!
Thank you oshimagun.
Only deleting preference file didnt work.
AHH! This has worked for me!! I have been searching online for about an hour and finally found a solution to my problem! I had tried "trashing" preferences but that was not the solution. THANK YOU SO MUCH!
Hmm, interesting.

I have a similar prob, which is very annoying, I had it in CS and now in CS3 Extended.

When I use the 'Open as' command, I get:
"Could not complete your request because it is not a valid Photoshop document" (yet it's a JPG) - works ok if I just usen File >Open.

When I try and shut/close down the file/program, I get:
"Could not complete the Close command becuase there is not enough memory (RAM)" Yet I have 1GB.

Any clues?
> Tany
When you go to open a file as, the first option is a psd file and if you dont change this to something like camera raw then you will get the message that its not a valid file format. I presume you were trying to open the file as a camera raw file
Thank you so much, I was having this exact problem, and now it's solved!!!!!!
I got this error because my default printer was an inaccessible network printer. I set the default printer to microsoft xps writer and it just worked.
all you need to do is create a new account in the control panel and your photoshop will function normally
Just create a new account? How do you transfer all your data from one account to the new account?
> larock56
You don't need to create a new windows profile, Just go to:

- C:\Documents and Settings\*your windows profile name*\Application Data and rename the adobe folder to "adobe_old"

then go to:
- C:\Documents and Settings\*your windows profile name*\Local Settings\Application Data and also rename the adobe folder to "adobe_old"

start photoshop

This method forces photoshop to re-create those adobe folders with the default files, as if you created a fresh user profile.

Hope this helps, it fixed the issue on my PS CS3

- Ivo
I had this same problem and the renaming of Adobe folders worked perfectly! Thanks!
Wow.. :D It's great, it solved my BIG problem.. thanks a lot, as in a lot.. :D
have the problem vith versioncueui.dll and did that with renaming and it didnt solve the problem
Registration date
Wednesday February 20, 2008
Last seen
February 6, 2009
I hope its not a cracked version that can retreive updates from the site.. It will get corrupted automatically...
Hi, Im new to this help and advise site. I bought "CS3 Creative Suite-Standard Edition". I started to get error message with CS3, For a whole week I phone Adobe technical support dept and tried to get help, but all in vein, no email address for support either. I deactivated the programs 1st and than I uninstall it from control panel. I still could not re-installed CS3. there was no setup exe file. Last way out, I format my hard drive, install XP.

This time I manage to install CS3. Only problem is I cannot open "Photoshop program". The error message is as follow:

"The specified module could not be found. C/program files/commonfiles/Adobe Version Cue CS3/Client?3.0,0/VersionCueUI.DLL" After pressing enter the followwing errror message comes up:
The instruction at "0x5ad71531" referenced memory at "0x00000014". The memory could not be "read, click on "OK" to terminate the program.

Im busy with my graphic design course and I really, really need to have my CS3 up and running.

Please, THIS is my only help.

Your help and advised will be appreciated. thank you inadvanced.

I called tech support and the solution to this problem is related to version cue. Make sure you have version cue unchecked in your photoshop options wherever it is--i cannot remember. And uncheck version cue in the startup scripts in the Bridge options.

The version cue option was under preferences > file handling.

It works for me.
Same here, I have just installed the adobe creative suite 3 master collection, and am not able to choose photoshop Cs3 extended, as the default program, nor does it allow me to open the files from abode bridge or use photoshop to edit from dreamweaver...does anyone have any advice? and by the way I am running off of Vista Home edition...
i had the same problem

in my case it was a microsoft security issue
i had to do the following:

1. go to your photoshop programs folder (i.e. C:\Program Files (x86)\Adobe\Adobe Photoshop CS3)
2. right click on photoshop.exe and click properties
3. go to the compatibility tab and checkmark 'run this program as an administrator"
4. go to the security tab and click on the advanced button at the bottom
5. select your login name and select edit, check mark 'allow' for everything
6. I had to uncheckmark 'include inheritable permissions from this object's parent' and hit 'remove' when the dialog popped up.

after that photoshop was working properly for me.
Hi, im jordan.
umm I got this Program from my brother he gave it to me through yahoo messager and I downloaded great nothing wrong, until I open it up and then the screen come up then it just go off. idk whats wrong wit it but I need help HELP!! ME!!!
Jinnie's fix worked for me! Rock on!
Hello, I am a graphic designer..and like everyone else. having problems with photoshop CS3.

It started randomly a few weeks ago or so, and I cant find out the problem, id open photoshop, go to open a new on the file, and as soon as it is suppose to open a command error box comes up saying that no photoshop files can be opend because there is to many files open at once.

but theres none at all.
After this box is closed..i cannot close photoshop...x out ur even CTRL ALT DEL out..i litrally have to restart the whole pc

its becoming a very serious issue as I need it for my work and do not expect to have to sit and spend the time creating a new account or reloading the software all over again when I havent had it that long.

this is a fault that needs to be fixed from design softwares.
there valuable..and important..and luckily I have not lost work from it.

although this is affecting my buisness and am finding it difficult or impossible to work from home at all.

what is the solution? Please tell me u have one!!
Jazz I think I am in a very similar position as you, I run a graphics forum. I am the only artist. And photoshop cs3 will allow me to open a file, but when I go to save. the screen comes up briefly than disappears. Than its locked up, but with me I can still take snag it and capture the photo...but I cant do this everytime. Did I press something wrong, did u find a solution. i've tried reinstalling, rebooting, safe mode, preference clean, I tried the control shift s thing nothing...
Nothing helped, then I pressed CTRL-ALT-SHIFT while starting PS. I was asked if my pref-file should be deleted and I confirmed. HOT DOG!

Btw: no effect on the workingspace setting, these remain and can be loaded (if saved before) so it's no big deal.
Registration date
Tuesday January 8, 2008
Last seen
February 20, 2008


I can think to several solutions to solve your Photoshop problem.

First, how did you set up your scratch disk? Did you put it on a separate drive than the one of the windows scratch disk? You'd need two different physical drives to do this, so if you only have one, then don't worry about it.

Also, how many fonts do you have loaded into windows? This might impacts Photshop too.

You can try trashing your preferences first (hold down ctrl, alt and shift when you start Photoshop) and see if that helps.

HERE's a link to some useful information from the Adobe website (

Hope one of these solutions will work for you!

Let's keep in touch.
I'm getting this issue as well, please help!
Did anyone try contacting Adobe....Or Microsoft? I know it can be painful trying to contact a large company....I just bought Photoshop cs3 last week and have no problems. I hope I dont run into this type problem.. I wish you all the best. Mike/ezdate123
I have the EXACT same problem on my laptop. I have CS3 installed on my desktop (that was a pain - took a lot of screwing around to get it to work) - I then installed it on my laptop and still can't get it to work. The first error was something about licensing - I found a solution - now I can't open files - I am getting the same error as you. I will be calling ADOBE tomorrow. If anyone has a solution, please post

There is an article on Adobe about this.

My solution was to create a new user account. It has something to do with your settings going corrupt when incorrectly shutting photoshop down
any other ideas?

I have tried every solution I cound find on the web and I still get the same error when trying to open a file?

I thought microsoft was bad for bugs - ADOBE is far worse!

I sure as hell hope that ADOBE doesn't try writing an operating system!

Registration date
Wednesday February 20, 2008
Last seen
February 9, 2009
Hi, is it a full version of cs3?
I had the same issue - per adobe it has to do with the dialouge opening in a place where it was previous -- this would be unavalable under certain conditions as it is restoring it to the previous - now unavailable - location. Mine was missing cause I had swapped the window to screen 2 in my setup - then returned it -- it can also happen if you change reolutins and the window is opening out of screen --- up the res and find the window and return it
Well after all the pain in the neck...I decided to format my hard drive and did a re-install. So far adobe CS3 is not giving me any trouble...and does works wonders!

There isn't enough info out there yet, so if you have the time and knowledge I would re-install it on a fresh hard drive.

That's what worked for me.
Thank you to everyone for your posts. Adobe should be paying you for performing the technical support that they can't seem to offer.

In any case, I just started having this problem about three hours ago. I was happily editing some photos today and PhotoShop CS3 just froze. From that point forward File > Open caused quick screen flash and then basically PS crashed (except that it stayed open and I had to force close). I have been looking for any and all information I can find and have tried everything short of re-formatting. Nothing worked until I saw the post about creating a new user account and that resolved the problem. It's a bit of a pain having to set certain things up again, but look at the bright side, if your desktop is really cluttered, you can start fresh under your new user account! I hope this works for others.

I also saw this tip on another site: Try this-open up windows explorer (short cut is the windows key and "E"). Minimize it. Now, open up PS and maximize it (so it takes up your entire screen). Go back to windows explorer, and make it so that it takes up maybe a quarter of your screen. Find a photo in windows explorer and with your left mouse button, click and hold, then drag it over the background of photoshop and release the left mouse button. This is another shortcut for opening in PS. So if you don't mind drag and drop, this might be a decent workaround.

Good luck and thanks again for your helpful advice.
> LyndieLou
Hi guys apparently the issue is very simple to solve. it is happening because the saving dialog box is not in the same screen. to fix this issue what you need to do is. open photoshop. press CTRL + O. move the open dialog box to the side which is comfortable for you then open a file . peess CTRL + SHIFT +S . the dialog box will open in a flash and disspear. and photoshop will is actually not hung but you cant do anything with the file because the save as dialog box is still open. but you cant see it because it is not in the screen but outside .just press enter at this point of time to save your file. try opening and saving another file and your save as dialog box returns to its normal position
> kunwar
It worked Kunwar

> kunwar
Thank you so much! This worked like a treat.

I read somewhere else to just turn off Version Cue, which worked too but not as good as the advice you suggested.

Thanks again :)
this means, the problem is the Photoshop CS3 setup shares the files in two folders. one is the root folder, with name Adobe, and some number of files in the folder by name "Common files". May be, the folder which are inside the Common Files folder might be unfortunately deleted or moved, this causes the particular error saying that some DLL files are missing when the photoshop is tried to being used. If the Setup is available try reinstalling photoshop again. Be sur that there rare no files left after uninstalling the older one(including registry).
-press ESC after attempting to open a file
-pressing CTRL+SHIFT+S (save-as) supposedly resizes the window to it's default size.

Thank you for this solution. It worked for me!

I was having the same issue with Photoshop and all other programs in the CS3 suite. Did this in Photoshop and it fixed them all.

Your are a life-saver!
Thnx, esc did the job after running a filter over a bigsize photo I couldnt open anything.
you're the best :-)
I need help here:

- When I Open an image in Adobe Photoshop CS3, the Open box opens and when I select an Image and click the Open button, an error comes out and says that it could not open because one or more files were selected for opening at once. So I've clicked OK and my photoshop just locks up! I mean I couldn't press any buttons in Photoshop even the Maximize, Minimize, and Close button.

- When I Save, I also get the same problem from above ^!

i have a solution for Dale's problem.

when you have several adobe softwares installed, most of them share the same components. most Components are left behind in the directory even if you uninstall the software that's why when you decide to reinstall the same software, in doesn't really overwrites the existing component and skips it during installation resulting to other components not being installed and skipped.(ex. VersionCue.dll, VersionCueUI.dll etc.)

the solution :

before installing (say, Photoshop CS3) check if you still have a folder named "Adobe" in your C: directory.
if you have one, then you should rename it temporarily with a new name.
- install the new adobe software.
- after installation, copy the new files from the new Adobe directory generated by the installation to the old Adobe folder you just renamed.overwrite any old files there.
-rename it back to Adobe

it worked for me. hope it does for you guys