Leopard OS Installer Does not recognize HD [Solved/Closed]

Report
Posts
1
Registration date
Saturday December 13, 2008
Status
Member
Last seen
December 15, 2008
-
 Clueless -
Hello,

Recently my son had the 160GB HD on his Mac Book Pro 15 replaced with a 320GB. The HD replacement was done by a 3rd party and they used data transfer to copy the data from the old HD to the new. It boots up fine when you power the MBP up. The startup volume shows up on the desktop. However, when trying to reinstall the Leopard OS from the Installer DVD, the Installer does not see the startup HD. The utility function on the Installer does not see the startup HD. What needs to be done to get the Installer to recognize this new HD?

11 replies

I had a similar problem. Leopard installer did not recognize the Macintosh HD partition. Disk Utility did. Repaired Permissions and the Leopard Installer detected the Macintosh HD.
24
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 2794 users have said thank you to us this month

Thankyou so much!
well if it doesnt reconize it how do you erase something that is there
What if mac wont boot and the hd doesnt show when I run installer.
Must partition the hard drive first. use any mac install disk. Do not run install go to utility's and you only need to use 400 mb after partition you can install whatever you want on it.
May God bless you, Papischmurf! I was *freaking out!!**, but these instructions saved us! Thank you! Thank you!!
i see that the request was submitted quite a long time ago, so maybe you found an answer already. but for future fellow macbook users who want to upgrade their hard drive.. here is the answer
before installing the leopard dvd go to disk utilities under the utilities tab and format the drive. I used mac (journaled) and it worked. have fun!
There are more people with this problem. Seems to be a problem with western digital drives. The leopard installer CD will see the drive if you open System Profiler, it will just not install to it (the installer itself is at blame).

Because initially you had the old system transfered to the new disk using 3rd party utilities, you have not seen the problem. An already installed system was copied over. Now, because you want to re-install, you stepped on the problem.

Maybe you should try to exchange this drive for another brand, or again install in another machine/HD and copy it over.
What we ended up doing was go to an Apple store and had one of their store techs reinstall the operating system from one of their portable drives.
Posts
1
Registration date
Friday May 28, 2010
Status
Member
Last seen
May 28, 2010

I just installed my new Western Digital WD10TPVT 1TB laptop hard drive in my shiny new 15" MacBook Pro. The advice here was helpful - thank you. I'm new to Mac. I had the same issue - installer did not recognize the drive. In my case, all I needed to do was go into disk utilities and erase (format) the drive and wamm-o blamm-o, the OS is happily installing right now! I'm psyched!
If the Installer see the Hard drive (HD) but not volume then you are able to do something but If the HD it's self does not show up then you have a problem.

If HD shows ( Ex; 320.01 GB WDC WD3200JD) then you can repartition drive (see tools ON DVD)

To allow old data you need to back up data (Leopard Has a good tool called Time machine for this) needs a external HD to complete then you can re partition Hard drive and reinstall OS {operating system} and then transfer files over via Migration ( what should have been done in the first place)
Guys, this works for ME! Thanks..!!!
I am having the same problem, except I can't even erase (partition) my drive. Whenever I try to erase my hard drive the operation times out. It pops up and says "Error, operation timed out". I have also tried to partition my hard drive using third party software, including Parted Magic, but the OSX installer still will not recognize my hard drive. I am using an Intel Mac Pro.

Thanks.
I had issues since I bought the WD 1.5 TB hdd, the transfer rate was lagging when copying either from the iMac hdd or another WD external hdd (over 30 minutes for a 600 MB file).
So I decided to erase and create a new partition, now I have the same problem as jckbac9, I can't erase nor partition the drive.

I get the "Timed out" error after 5 seconds.
thanks! huge help

Hi,
It's an old thread, but I'll respond as I looked everywhere for the answer and didn't find it. In my case, the problem was the cable that connects the HD to the motherboard. So it was a hardware problem that caused the POSIX can't allocate memory error.
The Apple store replaced it for free. Within three days. They were as baffled as I was that the HD worked thru USB and not internally.
Hi there.

I had a similar problem (same really) I only upgraded to .5 TB and cloned my original disk to my new HDD. I would try to back up all your files and reformat the HDD and attempt a re-install. It has worked for me and I hope it will for you!

grumpy

try going to the bar at the top and choosing Utilities, then click Disk Utility. If you want to delete everything, choose erase, then name it and select Mac OS Extended (Journaled). If you still have no luck, try going to partition, clicking above the boxes where it says current, and choosing 1 Partition. Then, choose options and make sure it's on GUID (i believe, the one that says for Intel Macs). Hope this helps! best of luck