I cannot access my C drive (Access denied).

Closed
Johnie - Aug 26, 2010 at 03:19 PM
jack4rall
Posts
6428
Registration date
Sunday June 6, 2010
Status
Moderator
Last seen
July 16, 2020
- Sep 2, 2010 at 05:33 PM
Hello,

A friend tampered with my laptop's Drive C property (security/sharing) configurations. (Right clicked and changed sharing/security settings) to restrict everything including Administrator's control over it. It now reads "Access Denied (C)" The effect is that I cannot make any changes on any of my documents, I cannot make changes and save, copy or transfer any of the documents even to another storage device. When I try to do that it just brings a dialogue box saying "Access Denied."

When I try running msconfig under the task manager it tells me "The parameter is incorrect..." The same message shows even when I try using any of the Administrative tools under the control panel.

When I right-click and go to sharing it reads C:\Shared \\Johnie\c

When I go to security it tells me "Cant open control access editor. Access is denied.

And oh, the operating system is Vista Premium, brand is toshiba satellite Series

A technician here tried and failed yet I really need to access stuff in there. Please 911.


1 reply

jack4rall
Posts
6428
Registration date
Sunday June 6, 2010
Status
Moderator
Last seen
July 16, 2020

Aug 27, 2010 at 05:31 AM
Hello,

Try this 1.

Open "My Computer" --> Tools --> Folder Options --> Click on "View" tab -->

Scroll down and uncheck the check box "Use simple file sharing" --> Click on "OK".

Now right-click on your C-Drive --> Select "Sharing and Security" --> In the

"Sharing" tab, select the option "Do not share this folder" --> Click on "Apply"

button --> then click on "Security" tab --> In "Group or user names:" section,

select your User ---> then in "Permissions" section --> check the check box "Full

Control" only in "Allow". This is select all the options under the "Allow" Column.

Note : If you don't find your user name in "Group or user names:" section, then

you can select the Everyone Or Click on "Add" --> In "Enter the object names to

select", enter your user name and click on "Check Name", then click on OK -->

Apply --->OK.

Good Luck.
0
Hi Jack, thanks for your effort and time,

I just tried following the above but still unsuccessful. First, if I got u right, the "folder options" is only available under the control panel. And when I scroll down I cannot find the "Use simple file sharing" option. The closest match to that is "Use share wizard recommended" but even when I try to check or uncheck that it has no effect. I still get the stinging message; access denied from where I can go nowhere.

Meanwhile someone was advising me to run the laptop on a Linux cd, copy the files on an external disc then reinstall everything. Do u think this can work?
0
jack4rall
Posts
6428
Registration date
Sunday June 6, 2010
Status
Moderator
Last seen
July 16, 2020

Sep 2, 2010 at 05:33 PM
Hello,
Try this 1.
Run from linux live cd and backup your data from that drive.
Then in windows uncheck that option "Use share wizard recommended" and click on OK.
Then right-click on your OS drive ---> properties. Look for the permission and security tabs.
Add the user both and check the full control option.
Good Luck.
0