Problem with RAM slot on Acer Aspire One

CDM - Sep 3, 2010 at 07:15 AM
 CDM - Sep 3, 2010 at 10:44 AM
Hi all,

I have a peculiar problem with my Acer Aspire One AOA 150. It was working fine till one fine day it just would not boot. Tried flashing the BIOS but had no luck. After much trial and error, managed to get it working by removing the 512 MB RAM from the additional RAM slot. Now whenever I add a RAM chip to the slot (tried 3-4 chips) the system does not even get to the BIOS stage.

Otherwise it works fine with the onboard RAM (the additional RAM slot being empty).

Any suggestions?



1 response

Blocked Profile
Sep 3, 2010 at 08:41 AM
Hi there,

Its clear enough that by trying other rams in the slot its not working and the slot has been damaged thus either you continue with minimum ram or add the highest capacity of ram in the slot or change the motherbaord.

Thanks Netsa77.

Can a RAM slot just fail like that? I am just curious because the laptop was working fine when shut down and thereafter would just not boot up.