Acer travelmate 2480 motherboard failure?

Closed
Sujantra
Posts
1
Registration date
Sunday November 7, 2010
Status
Member
Last seen
November 7, 2010
- Nov 7, 2010 at 02:45 PM
jaguillen
Posts
1
Registration date
Sunday November 7, 2010
Status
Member
Last seen
November 8, 2010
- Nov 8, 2010 at 08:41 PM
Hello,
I have an ACER TravelMate® 2480-2968 (LX.TH30Y.072) HDD WD 80Gb, Celeron 1.86 1.5 Gb ram Bios version 1.305 that has booting failures. All the problems begun when I updated Vista. After a few updatings the system began to fail, when it was started an Acer logo screen was displayed then black screen for more than 10 minutes. Then it started up with an acer screen asking me to select from launch windows fail probe or start normally. For some time it was possible to start windows with the last option but some day displayed system failure. I tried to repair the system with the Vista recovery disk but always asked to load HDD controllers. I could not continue from that point.

Since the booting failures begun the HDD was not recognized in the bios setup. The bios setup does not offer the option to change HDD parameters and have no HD autodetection. also I could not do the alt F10 neither F12. I was able to boot changing the booting order from the CD drive with vista installing disk and got the command but it cames out with a X :/windows/system32/directory and I could not see the c: drive.

Now the does not starts from CD anymore, when it is turned on HDD led blinks once while is posting and twice after posting of ram, sram, (test passed) and system and video bios shadowed but when CD test is performed starts a constant beeping like when you hold down a key. The posting finishes with mouse inicialitiazed, CD tray's led blinks while is reading Cd disk and I can heard that disk spins, but no boots from this drive.

Then the bios setup utility is displayed without pressing F2, if I exit the setup, the system resets and turns on again with a loop: posting, beeping, bios setup and system resets.
I checked HDD connections, bios configuration but only a cursor key is not functioning. Someone told me that motherboard is going to die, but the posting test it seems to be OK. It would be necessary to flash or update the bios setup? Could be a keyboard failure because of the strange beeping? I don't know how to do in order to solve this problem. Any help is appreciated.

Thanks,

Sujantra

1 reply

xpcman
Posts
19532
Registration date
Wednesday October 8, 2008
Status
Contributor
Last seen
June 15, 2019
1,829
Nov 7, 2010 at 11:16 PM
This sounds like a hard disk failure. A computer shop should be able to replace the drive.

Good Luck
1
jaguillen
Posts
1
Registration date
Sunday November 7, 2010
Status
Member
Last seen
November 8, 2010

Nov 8, 2010 at 08:41 PM
Hello
Thank you for your message, I'm going to try with a new HDD I hope it will solve the problem.

Sujantra
0