Razer Megalodon 7.1 headset problem. [Solved/Closed]

- Jan 3, 2011 at 04:18 PM - Latest reply:  Leo - Jan 27, 2011 at 09:50 PM
Hello,

I recently bought this headset in hopes for improving online FPS gaming experience... Basically what it means I wanted to hear footsteps of people...

Well after hours of trying all sorts of stuff I still don't hear footsteps on Neither call of duty modern warfare 2(with or without Ninja Pro/Sitrep Pro) or black ops...

I updated my realtek driver just now but still I can't hear footsteps...

I would appreciate very much any assistance, thank you to anyone willing to help


See more 

2 replies

Best answer
2
Thank you
Realtek Audio Driver??

Razer made these headphones "Plug and Play". They are NOT part of your Realtek Soundcard, instead they use a generic Audio Driver.

My suggestion. Disable your soundcard in BIOS, so that your computer will recognise Razer Megalodon only. To check, Right-click My computer>Properties>Hardware>Device Manager>Sound, video and game >LOOK FOR USB AUDIO DEVICE

Also, make sure that your stimulated speakers all have volume by pressing the Razer Logo and adjusting accordingly.

Also be sure that your audio settings on both headset and game are correct. Make sure that in COD you have it set to , but then set your headset to 7.1 (by pressing MAELSTROM, LOCATED AT TOP OF CONTROL POD)

To reset all settings, hold down the Razer logo for about 15 seconds.

Hope this helps you bro, good luck.

Thank you, 1337guy 2

Something to say? Add comment

CCM has helped 1695 users this month

0
Thank you
Thanks for the effort bro, I guess I expected too much from this headset, I set it on 7.1 but everyone uses ninja and whatnot so I hear nothing, no footsteps but again thanks.