Toshiba Satellite C650 NO BOOTABLE DEVICE

Chris - Sep 18, 2011 at 01:45 AM
 Kim - Apr 30, 2016 at 04:09 PM
Hello, I have a Toshiba Satellite C650 and is only 13 months old and need it for my business - It is windows 7 - crashed 3 days ago and when turn on says check cable connection - PXE-MOF: eXITING iNTEL pxe rom - no bootable device - INSERT BOOT DISK AND PRESS ANY KEY

I have tried other suggestions in the message board but unfortunately none of them work - Any suggestions please will be very grateful

1 reply

Blocked Profile
Sep 18, 2011 at 02:25 AM

Try booting from windows installation cd and make a repair if no hard drive found message appears then you will need to replace hard drive,then to get all your data back purchase an external enclosure of 2.5 inch and fit the old hard drive it in and use as external device where all information will be there .

Good luck
Thanks ever so much for quick response. Unfortunately I do not have a windows installation cd either! The laptop came with nothing!! I have a Dell reinstallation cd but guess that won't work either!! I have managed to press f2 now and that brings up the set up info, is there anything on there I can change to help??
Ironically went into f2 and changed boot to fast from medium and now when switch on can not access f2 but get a flashing white line in top right corner and can not do anything else - could it be rebooting itself ???
hi I have the exact same probem, did you end up getting it sorted and if so how??
Hello I have a c655 but it tells me the same thing, it happened after my brother tried restoring it. He accidentally deleted or wiped the hard drive so now I'm left with that. Would the disc help me get it working?
OK, so I used F2 and changed the boot speed to normal. I also changed some SATA setting. It recognized the new hard drive I put in it in the BIOS.