Keyboard Malfunction

Closed
Opneilso Posts 4 Registration date Wednesday November 28, 2012 Status Member Last seen November 29, 2012 - Nov 28, 2012 at 09:03 AM
Zohaib R Posts 2368 Registration date Sunday September 23, 2012 Status Member Last seen December 13, 2018 - Nov 30, 2012 at 03:52 PM
Hello,
This morning a number of the keys on my keyboard took new values, 'backspace' has become '=' with Numlock on or '2=7' with it off.
I've tried following suggestions on various forum sites, going through the control panel and changing language, or using the Fn, ScrollLock, NumLock keys, also with the On-Screen Keyboard, but nothing works.
Any help would be much appreciated.
Thanks


Related:

7 responses

Opneilso Posts 4 Registration date Wednesday November 28, 2012 Status Member Last seen November 29, 2012 1
Nov 28, 2012 at 09:23 AM
Hi Zohaib,
I followed your advice, deleted Italian-US and left only UK, but it's still the same. I was just trying Ctr+Shift and it changed the 'backspace' value to '['
But now it's back to deleting a space and adding '='
Regards
Zohaib R Posts 2368 Registration date Sunday September 23, 2012 Status Member Last seen December 13, 2018 69
Nov 28, 2012 at 09:16 AM
Hi Opneilso,

This problem might happen if there are multiple language keyboards selected in Text Services and Input Languages. To remove additional languages from Text Services and Input Languages:

1. Click Start and type "Region and Language" in the search box.
2. Select "Region and Language" from the search results.
3. Click Keyboard and Languages tab
4. Click Change keyboards...
5. Click general tab
6. From Installed services remove any other unwanted language.
7. Click Apply.
8. Click OK.
9. Finally, click OK on the Region and Language window.

Do reply with results.
Zohaib R Posts 2368 Registration date Sunday September 23, 2012 Status Member Last seen December 13, 2018 69
Nov 28, 2012 at 12:12 PM
Hi Opneilso,

Try the below mentioned steps and see if the issue is fixed:

1. Try to boot the computer to Safe Mode and check if the keyboard behavior is same. To boot the Safe Mode, power on/restart the computer, start tapping the F8 key, select Safe Mode from the Advanced Boot Menu that appears.

2. If the keyboard is working fine in the safe mode, perform a clean boot. To get the steps on how to perform a clean boot, check the below mentioned link:

https://support.microsoft.com/en-us/help/929135/how-to-perform-a-clean-boot-in-windows

Do reply with results.
Opneilso Posts 4 Registration date Wednesday November 28, 2012 Status Member Last seen November 29, 2012 1
Nov 28, 2012 at 03:01 PM
Thanks Zohaib,

Unfortunately, it didn't work.
There were the same errors on the delete keys as in the normal mode, and neither Enter button worked.
I looked in the control panel etc as in normal mode, the only thing was this error message when I tried to change settings, "Unexpected Error Keyboard Control Panel (0x80004005L)
All letters and numbers as you can see work fine.
About an hour ago it was randomly switching the ScrollLk or NumLk on, and scrolling indiscriminately, or opening and closing windows. But, it's stopped that now. Not sure if that was because I pressed Fn/Ctrl/Shift in various combinations.
Thanks again for the help, and more ideas?
Regards

Didn't find the answer you are looking for?

Ask a question
Zohaib R Posts 2368 Registration date Sunday September 23, 2012 Status Member Last seen December 13, 2018 69
Nov 29, 2012 at 03:31 PM
Hi Opneilso,

Let's try the following steps to troubleshoot further:

1. Plug or reseat the keyboard connector (Note: if you have a laptop you might need a technician's help to do so or you can refer to the Service Manual of your laptop. Ensure all the power connections including battery and external devices are removed before you open computer chassis).
2. Verify there are no broken/damaged pins or damage to the cable. Replace the keyboard for damaged pins/cable.
3. Boot the system to the DOS prompt (Click Start type cmd in Run) to test the keyboard.
4. If the keyboard works fine on DOS Prompt, reinstall the keyboard driver, if there is keyboard driver for your keyboard.
5. Check the Accessibility Options (Click Start type Ease of Access Center and hit Enter) in the Control Panel (options on Keyboard tab should be unchecked).
6. Swap with a known good keyboard (if available). If the known good keyboard works, replace the Keyboard.

Do reply with results.
Opneilso Posts 4 Registration date Wednesday November 28, 2012 Status Member Last seen November 29, 2012 1
Nov 29, 2012 at 03:47 PM
Thanks again for the advice. I think for this I need to take it to a technician.
Regards
Zohaib R Posts 2368 Registration date Sunday September 23, 2012 Status Member Last seen December 13, 2018 69
Nov 30, 2012 at 03:52 PM
Hi Opneilso,

Kindly let us know the status after visiting the technician. Thank you for writing to us.