External HD wants to format - Can't Access [Closed]

rationalgaze - Feb 13, 2009 at 12:27 AM - Latest reply:  Swift
- Jun 21, 2011 at 10:38 PM
Last night we had some power shortages. My external HD was plugged in but wasn't transferring data. However, when attempting to access it this morning it tells me the drive is not formatted and I need to format it before I can use it. I still have ALOT of data on there that I need.

Is there any way I can get the data back or access the drive again without using a program? I currently have 9 hours remaining on my scan of the HD to recover data, but I don't even know how effective it will be.

Thanks in advance.
See more 

14 replies

+12
Helpful
8
My response is a little old, but you never know who it could help. I had not plugged in my hard drive for a minute and actually thought I had misplaced the AC adapter during this last international move. Somehow, when I tried to access the information on my WD external hard drive, I got a message asking me to format the drive if I wanted to use it. The drive registered, but showed 0kb, like it had spontaneously self-deleted all the files.

However, after reading everything here, and nothing worked, I decided to try a partition restoration software. It is called Active Partition Recovery out of Canada. I bought the $40 version after spending hours trying other things to scan it, etc. I could see the files. I simply right clicked on the drive to restore the boot sector and everything reappeared.

Just thought I would pass it along.
Was this answer helpful?  
Thanks again marciara!

Had the same problem with an external HDD (Seagate) and got the dreaded "format disk drive" pop-up...

So I've downloaded the software you suggested Active Partition Recovery and after clicking on "fix boot sector" it recovered my external HDD!!! (had to do it a couple of times... somehow didn't get it first time - not sure why)

Backing up all my files to DVD now!

I'm using Windows Vista btw...

Many thanks!
do you know if this software works for a mac?? I am desperate! I sent my hd to a data recovery place (ECO Data Recovery), and they are telling me that it looks like a brand new hard drive w/ nothing on it, and it's asking them to format. I thought all was hopeless, but after reading this I now have a little hope.
i have the program (active partition recovery) and did the superscan.. but I can't fix my hard drive and it stills ask me to format... anyone knows what I have to do at the program
to fix the hard drive?
THANKS A LOT MARCIANA!!! AFTER SEARCHING FOR 2 DAYS I FINALLY FOUND THE WAY THANKS TO YOU!
M.
This might be late for some, but I've had the same issue with my WD 1TB external after I disconnected it for one computer and reconected it to another (not sure why it happened).

After trawling through forums I found this thread and tried 'Active Partition Recovery' but to no avail. It was suggested by a friend to try "GPartED" a free partitioning software to see if that would work, but when I booted into the Linux shell it said "boot sector damaged".

Eventually I came across a feature of a program 'Partion Table Doctor' called 'fixboot'
(see http://www.ptdd.com/fixboot.htm), I 'acquired' the program (*cough cough* thepiratesomethingorother* ;-) ) and installed it.

As soon as Partion Table Doctor loaded it informed me that the drive had a damaged boot sector and suggested running 'fixboot'. Happily I did just that, selected the 'auto' fix option and after 2 days of heartache PTD had fixed the drive in 2 min!
vistaXpert 7 Posts Thursday January 1, 2009Registration date June 3, 2009 Last seen - Feb 13, 2009 at 04:14 AM
+2
Helpful
hi,
you may try it in another computer And see if it detects the hard drive.
if it detects, you will have to backup the files on some DVDs.
then you may format the drive.
+2
Helpful
2
As per suggested I used Active Partition Recovery and after clicking on "fix boot sector", within a matter of seconds my ext hdd was working and accessible, and no more asking me to format the drive.

Thank you so much for sharing this.
I did this and windows is still wanting to format the disk, am I doing something wrong? I feel like ive completely wasted my money. I have windows vista and my drive is a freecom xs 1tb drive, any other suggestions?
Nia, try 'Partion Table Doctor v3.5' - it has a feature 'Fixboot' - worked for me when Active Partion Recovery didn't (see comment above).
rationalgaze - Feb 13, 2009 at 08:14 AM
0
Helpful
It detects the hard drive in either computer. The problem is, it doesn't recognize the hard drive as having data and instead says it needs formatting.

I addition, once my "data recovery" software finished it restarted my computer before I could save the data, thus making the last 9 hours pointless.