Folders deleted once and a new folder named with previous delete [Solved/Closed]

Report
Posts
1
Registration date
Saturday May 4, 2013
Status
Member
Last seen
May 4, 2013
-
jack4rall
Posts
6499
Registration date
Sunday June 6, 2010
Status
Security contributor
Last seen
October 6, 2019
-
Hi
In my 500gb seagate external harddisk.After my friend used it in her PC and gave back my PC detected a lot of virus which i removed. But still already present folder say 'a' in the harddisk was displaying as shortcut file of d name 'a'. i deleted the shortcut and tried creating a new folder with same name 'a' but it says that there is already folder 'a'. :( i tried unhiding the folders if any form control panel.but it is not working. Please tell me how to fix this issue
thanks!
shruthi

1 reply

Posts
6499
Registration date
Sunday June 6, 2010
Status
Security contributor
Last seen
October 6, 2019
2,214
Hello,

Try this 1

There might be an autorun.inf file which is creating such an issue for you.

Follow all the steps given below

1) Disable the "Autoplay" feature. Click on the below link "Disable Autoplay",

and download the file --> Double-click on it and follow the instructions.

Disable Autoplay

2) Disable the "Autorun.inf". Click on the below link and follow the instructions.

First backup your registry. Click on Start --> Run --> Type regedt32 and press

Enter. "Registry Editor" will be opened.

Now backup your registry by going to "File --> Export" --> Save the file with

any name in your desired location.

Copy the text starting from "REGEDIT4" upto @="@SYS:DoesNotExist"

REGEDIT4                 
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\IniFileMapping\Autorun.inf]                 
@="@SYS:DoesNotExist"  

Open a "Notepad" --> Paste it --> Save the file as fix.reg

Note: Don't forget the extension "reg"

Now double-click on the fix.reg file and then click on "Yes" to merge it,

[Note : After following the above instructions, whenever you place any autoplay

CD\DVD all you have to do is go to "My Computer" --> Open the CD\DVD drive

--> You have to double-click on the setup file.]

3) Click on the below link and download the file "AutorunExterminator"

https://ccm.net/download/download-11613-autorun-exterminator

Extract it --> Double-click on "AutorunExterminator".

This will remove the autorun.inf files from drives.

[Note : AutorunExterminator need Dot Net Framework. If its not installed in

your PC then click on the below hyperlink ".NET Framework" and download it

.NET Framework]

Alternate Method :

To manually delete the autorun.inf file from the command prompt

Click on Start --> Run --> Type cmd and press Enter.

"Command Prompt" will be opened. Here I assume your external drive letter as g

del /a /f g:\autorun.inf --> Press Enter.

This will delete the autorun.inf file from your external drive.

4) Click on Start --> In search box, type control folders and press Enter.

[If you are using Windows XP then type control folders in Run and press Enter]

"Folder Options" will be opened. Click on the "View" tab.

Now select the option "Show hidden files, folders or drives" and uncheck the

check box "Hide protected operating system files" --> Click on "OK" button.

Now check your external hard drive for hidden folders with such names.

Later once again open the "Folder Options", click on "View" tab --> Click on

"Restore Defaults" button and then click on OK.

5) Click on the below hyperlink "Malwarebytes Anti-Malware Free" and

download it.

Malwarebytes Anti-Malware Free

Update it --> Perform "Full Scan".

Make sure you connect your external hard drive also.

Good Luck