Please help me with my WD HDD

Closed
Posts
5
Registration date
Wednesday June 26, 2013
Status
Member
Last seen
June 28, 2013
-
Posts
5
Registration date
Wednesday June 26, 2013
Status
Member
Last seen
June 28, 2013
-
Hi,

I've lost my WD hdd for about 5 months and haven't open it since it lost... i found it now but the problem is when i insert my hdd to my computer it appear as (local disk f:) but when i open it? its empty (even i reveal all the hidden folders nor type the files at the url box to search, it won't appear) i check its properties but the disk has 0 used and 0 free space...

is there any help to save my hhd? TT_TT

5 replies

Posts
8
Registration date
Tuesday June 25, 2013
Status
Member
Last seen
June 29, 2013
3
You have to try Disc Manger booting software and remove the bad sector of your HDD and repair the all boot media of your HDD. you have to RUN this software in Boot mode and hen follow the instruction on Screen.
Posts
5
Registration date
Wednesday June 26, 2013
Status
Member
Last seen
June 28, 2013

oh thank you for reply but i'm kinda bad with this, i'm not that good with computer is it ok if you tell me in details so i can do it my self Y_Y
thank you in advance! (BTW i try to manage it at my computer but cannot be detected.) the pc only detected the internal memory not my WD hdd
Posts
5
Registration date
Wednesday June 26, 2013
Status
Member
Last seen
June 28, 2013

and i forgot... i cant format the hdd too... TT_TT
Posts
8
Registration date
Tuesday June 25, 2013
Status
Member
Last seen
June 29, 2013
3
Check jhumper setting of your HDD and try after change again and again. If your HDD were not detecting so Jhumper will solve this problem. After all of that your HDD not detect then Check the BIOS settings but First HDD should be plug in on Motherboard.
Posts
5
Registration date
Wednesday June 26, 2013
Status
Member
Last seen
June 28, 2013

when i did what you said
here's the result
it appears "WD BAD PCB USB Device" this happen when i put the jumper at the 3rd slot of the jumper settings of my hdd... and the other slot is just normal like local disk f: and i haven't tried to plug in my hdd on the motherboard.. i'm still looking for some cord to use for my hdd, it's kinda different from my motherboard
's cord... is there a big trouble with that "WD BAD PCB USB Device"

it's ok to loose my data just want to recover my HDD... please... TT_TT

thank you so much!