Help with my pc

Closed
ZZMartiniZZ Posts 1 Registration date Sunday January 19, 2014 Status Member Last seen January 19, 2014 - Jan 19, 2014 at 02:39 PM
xpcman Posts 19530 Registration date Wednesday October 8, 2008 Status Contributor Last seen June 15, 2019 - Jan 19, 2014 at 02:48 PM
Hi i'm Martin. I hope you can help me...

I'm having problems with my pc for the past 6 months.

First of all my specs of my computer:
I have a Galaxy 9500Gt 1Gb display card.
A Amd Semphron 3000 processor with 1.6GhZ
I have 2x1Gb DdR2 Ram
I also have a 500watt powersupply.
I've got one 80Gb HDD and a 500Gb HDD.
And a DVD drive.

The problem is, that when i boot my pc up. Everything of my components are working fine and is in order. But my monitor says "NO SIGNAL". Then i reboot my pc and still the same.

Truelly i'm very angry and upset. I wanted to lan with my friend that day, but there bad luck struck.

I truelly hope someone can help me.
Best of regards
Martin
Related:

1 response

xpcman Posts 19530 Registration date Wednesday October 8, 2008 Status Contributor Last seen June 15, 2019 1,827
Jan 19, 2014 at 02:48 PM
All you know at this point is the monitor is not receiving a signal from the computer.

You need to check:
1. the connections of the cable to the monitor
2. the connection of the video card
3. the operation of the video card (can you try a different card?)
4. Is the computer booting-up or is the motherboard/CPU dead?
Does the computer play the Windows start-up sounds?
5. The health of the power supply

Perhaps you need the services of a local repair shop.

Good Luck
0