Write protection eradication

Solved/Closed
niteesh123 Posts 4 Registration date Tuesday February 4, 2014 Status Member Last seen February 6, 2014 - Feb 4, 2014 at 03:49 AM
Ambucias Posts 47358 Registration date Monday February 1, 2010 Status Moderator Last seen September 1, 2021 - Feb 6, 2014 at 05:42 AM
plz help me wid all possible solutions to eradicate write protection for usb flashdrives and memory cards.plz provide me wid d neccesary details abt d abstractions...waiting eagerly to know.

3 replies

Ambucias Posts 47358 Registration date Monday February 1, 2010 Status Moderator Last seen September 1, 2021 11,241
Feb 4, 2014 at 06:04 AM
Click start
then run regedit
go to this directory HKEY_LOCAL_MACHINE\SYSTEM\Currentcontrolset\control\
if you can't find StorageDevicePolicies under control folder
then make some new one. Follow this steps:

step 1:
go to this directory HKEY_LOCAL_MACHINE\SYSTEM\Currentcontrolset\control\
again and right click control folder

step 2:
select new, then click key and rename the new key #1 folder into
StorageDevicePolicies

step 3:
right click StorageDevicePolicies folder and select new DWORD(32-bit) Value
for 32-bit Operating System and select new DWORD(64-bit) Value
for 64-bit Operating System

step 4:
rename dword newer folder into WriteProtect, then double click WriteProtect
and change the value data into 0 with hexadecimal base, Then close regedit

step 5:
open my computer and refresh it 5 times without do anything to your usb, and
properly eject your flash drive

step 6:
plug in your usb again into your computer and format it using exfat instead of fat32
0
niteesh123 Posts 4 Registration date Tuesday February 4, 2014 Status Member Last seen February 6, 2014
Feb 5, 2014 at 03:23 AM
sry to convey that the above provided solution,is not working with my sandisk cruzer blade( 8gb) pendrive.
0
Ambucias Posts 47358 Registration date Monday February 1, 2010 Status Moderator Last seen September 1, 2021 11,241
Feb 5, 2014 at 05:06 AM
Open Start Menu >> Run, type regedit and press Enter, this will open the registry editor.
Navigate to the following path:


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies Double click the key WriteProtect in the right pane and set the value to 0
In the Value Data Box and press OK button
Exit Registry, restart your computer and then again re-connect your USB pen drive on your computer.
0
niteesh123 Posts 4 Registration date Tuesday February 4, 2014 Status Member Last seen February 6, 2014
Feb 5, 2014 at 10:58 PM
had given a try all d possible solutions conerning writeprotect error(register key ,formatting indirectly at my computer).actually while navigating the path it is specifying qword for 64-bit rather than dword....does this matters d protocol please let me know ,waiting forward eagerly.
0
Ambucias Posts 47358 Registration date Monday February 1, 2010 Status Moderator Last seen September 1, 2021 11,241
Feb 6, 2014 at 05:15 AM
please rename qword
0
niteesh123 Posts 4 Registration date Tuesday February 4, 2014 Status Member Last seen February 6, 2014
Feb 6, 2014 at 05:35 AM
thanx ambucias for all your patience concerning my query .i m excited to convey that it iz working with my pendrive..can u plz list me d abstraction of commands.
0
Ambucias Posts 47358 Registration date Monday February 1, 2010 Status Moderator Last seen September 1, 2021 11,241
Feb 6, 2014 at 05:42 AM
"list me d abstraction of commands" sorry, you lost me.
0