Write Protected

Closed
MeysamYazdan
Posts
4
Registration date
Tuesday March 4, 2014
Status
Member
Last seen
March 5, 2014
- Mar 4, 2014 at 09:10 AM
Ambucias
Posts
47366
Registration date
Monday February 1, 2010
Status
Moderator
Last seen
September 1, 2021
- Mar 5, 2014 at 07:17 AM
my flash not formated and Show this message:"The disk is Write Protected"
and In Mange of my computer don't Show Format.
plz help me.
thanks

3 replies

Ambucias
Posts
47366
Registration date
Monday February 1, 2010
Status
Moderator
Last seen
September 1, 2021
11,293
Mar 4, 2014 at 05:33 PM
Click start
then run regedit
go to this directory HKEY_LOCAL_MACHINE\SYSTEM\Currentcontrolset\control\
if you can't find StorageDevicePolicies under control folder
then make some new one. Follow this steps:

step 1:
go to this directory HKEY_LOCAL_MACHINE\SYSTEM\Currentcontrolset\control\
again and right click control folder

step 2:
select new, then click key and rename the new key #1 folder into
StorageDevicePolicies

step 3:
right click StorageDevicePolicies folder and select new DWORD(32-bit) Value
for 32-bit Operating System and select new DWORD(64-bit) Value
for 64-bit Operating System

step 4:
rename dword newer folder into WriteProtect, then double click WriteProtect
and change the value data into 0 with hexadecimal base, Then close regedit

step 5:
open my computer and refresh it 5 times without do anything to your usb, and
properly eject your flash drive

step 6:
plug in your usb again into your computer and format it using exfat instead of fat32


Now, you can use your flash drive again....
0
MeysamYazdan
Posts
4
Registration date
Tuesday March 4, 2014
Status
Member
Last seen
March 5, 2014

Mar 5, 2014 at 01:00 AM
hi
I'm sorry, not work
0
Ambucias
Posts
47366
Registration date
Monday February 1, 2010
Status
Moderator
Last seen
September 1, 2021
11,293
Mar 5, 2014 at 07:17 AM
Try this:

*1. Open Start Menu

*2. Run, type regedit and press Enter; this will open the registry editor

*3. Navigate to the following path:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies*

4. Double click the key WriteProtect in the right pane and set the value to 0 In the Value Data Box. Press OK

*5. Exit Registry

*6. Restart your computer and re-connect your USB pen drive on your computer.
0