How to kill shortcut virus on my laptop [Solved/Closed]

StitchesGh 2 Posts Sunday April 13, 2014Registration date January 2, 2015 Last seen - Apr 13, 2014 at 04:25 PM - Latest reply: jack4rall 6507 Posts Sunday June 6, 2010Registration dateModeratorStatus December 30, 2015 Last seen
- Apr 13, 2014 at 04:30 PM
Hello,



When I insert a pen drive or external drive into my laptop, I get so many shortcut file from all of my folders and files. How do I kill the virus on my laptop? Because I can clear all the shortcut on my pen drive but it appears anytime I insert another pen drive. Thank you!
See more 

2 replies

Best answer
Ambucias 53283 Posts Monday February 1, 2010Registration date July 20, 2018 Last seen - Apr 13, 2014 at 04:28 PM
2
Thank you
This type issue could be caused by a USB virus. It will spread to all of your USB memory devices and hard disk.

Here is a tool to remove the virus and vaccinate your USB against further viruses.


Download UsbFix (created by El Desaparecido) on your desktop.

http://ccm.net/download/download-24089-usbfix

If your antivirus gives an alert, ignore it and temporarily deactivate the antivirus.
Plug in all of your usb devices (Flash drive, pen drive. External HD etc...) don't open them.
Double click sur UsbFix.exe.

Click on deletion
.
Let the tool work.

The tutorial UsbFix , view : http://www.en.usbfix.net/2014/02/usbfix-tutorial-clean-option/

Ambucias
Moderator/virus security contributor

At the end of the scan a report will show which you can copy and paste here..

The report is save at the root ( C:\UsbFix.txt ).

You can also vaccinate against any virus.

Thank you, Ambucias 2

Something to say? Add comment

CCM has helped 1680 users this month

jack4rall 6507 Posts Sunday June 6, 2010Registration dateModeratorStatus December 30, 2015 Last seen - Apr 13, 2014 at 04:30 PM
0
Thank you
Hello,

Try this 1

There might be an autorun.inf file which is creating such an issue for you.

Follow all the steps given below

1) Disable the "Autoplay" feature. Click on the below link "Disable Autoplay",

and download the file --> Double-click on it and follow the instructions.

Disable Autoplay

2) Disable the "Autorun.inf". Click on the below link and follow the instructions.

First backup your registry. Click on Start --> Run --> Type regedt32 and

press Enter.

[If you are using Windows 7 then click on Start --> In search bar, type

regedt32 and press Enter]

"Registry Editor" will be opened.

Now backup your registry by going to "File --> Export" --> Save the file with

any name in your desired location.

Copy the text starting from "REGEDIT4" upto @="@SYS:DoesNotExist"

REGEDIT4                  
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\IniFileMapping\Autorun.inf]                  
@="@SYS:DoesNotExist"  

Open a "Notepad" --> Paste it --> Save the file as fix.reg

Note: Don't forget the extension "reg"

Now double-click on the fix.reg file and then click on "Yes" to merge it,

[Note : After following the above instructions, whenever you place any autoplay

CD\DVD all you have to do is go to "My Computer" --> Open the CD\DVD drive

--> You have to double-click on the setup file.]

3) Click on the below link and download the file "AutorunExterminator"

http://ccm.net/download/download-11613-autorun-exterminator

Extract it --> Double-click on "AutorunExterminator".

This will remove the autorun.inf files from drives.

[Note : AutorunExterminator need Dot Net Framework. If its not installed in

your PC then click on the below hyperlink ".NET Framework" and download it

.NET Framework]

4) Click on the below link and download the file "USBFix".

http://ccm.net/download/download-24089-usbfix

Open the USBFix --> Click on "Deletion" and follow the onscreen instructions.

After completion of "Deletion" process, click on "Vaccinate".

5) Click on the below hyperlink "Malwarebytes Anti-Malware Free" and

download it.

Malwarebytes Anti-Malware Free

Update it --> Perform "Full Scan".

Make sure you connect your pen drive also.

Good Luck