Problem with 1tb usb [Solved/Closed]

gobetago 12 Posts Saturday November 8, 2014Registration date January 30, 2015 Last seen - Jan 27, 2015 at 12:29 AM - Latest reply: gobetago 12 Posts Saturday November 8, 2014Registration date January 30, 2015 Last seen
- Jan 30, 2015 at 06:58 PM
Hello,

I just bought 1tb usb but my pc does not recognize it and its light goes on. I checked on other pc and its working fine.

My pc:

Dell Optiplex gx620
2gb Ram
Sp3

See more 

7 replies

Best answer
Boogieman_WD 275 Posts Friday October 10, 2014Registration dateCertified CCM ContributorStatus October 19, 2016 Last seen - Jan 27, 2015 at 02:52 AM
1
Thank you
Hey gobetago. If the drive is working fine on other devices, perhaps it just needs you to assign it a new letter. Here's a link with detailed instructions on how to do that: http://wdc.custhelp.com/app/answers/detail/a_id/137/

Just click on the instructions for the corresponding OS and follow the steps.

Hope that helps.
Boogieman_WD

WD Representative

Thank you, Boogieman_WD 1

Something to say? Add comment

CCM has helped 1695 users this month

Boogieman_WD 275 Posts Friday October 10, 2014Registration dateCertified CCM ContributorStatus October 19, 2016 Last seen - Jan 27, 2015 at 03:27 AM
From what I see, you're running Windows XP SP3. It should support HDDs up to 2TB without any issues. Do you have any similar problems with other USB storage devices? You could try reinstalling the USB drivers. And you could try if this fixes your issue: http://support.microsoft.com/kb/314634#LetMeFixItMyself
gobetago 12 Posts Saturday November 8, 2014Registration date January 30, 2015 Last seen > Boogieman_WD 275 Posts Friday October 10, 2014Registration dateCertified CCM ContributorStatus October 19, 2016 Last seen - Jan 27, 2015 at 07:59 PM
Had some issues with new USB mouse and i had to install drivers for it

I will download it and keep u updated may be it will solve my problem.

Regards
gobetago 12 Posts Saturday November 8, 2014Registration date January 30, 2015 Last seen > Boogieman_WD 275 Posts Friday October 10, 2014Registration dateCertified CCM ContributorStatus October 19, 2016 Last seen - Jan 28, 2015 at 03:10 PM
Again did not work after installing fix it, even it did not work on previous PC that worked fine for first time.
Boogieman_WD 275 Posts Friday October 10, 2014Registration dateCertified CCM ContributorStatus October 19, 2016 Last seen - Jan 29, 2015 at 04:38 AM
Perhaps there's a bigger problem and is connected with the drive itself. This guide affects the USB ports only for the computer you've changed the settings for and does nothing to the drive. Have you heard any unusual sounds/noises coming from the drive while using it?
gobetago 12 Posts Saturday November 8, 2014Registration date January 30, 2015 Last seen > Boogieman_WD 275 Posts Friday October 10, 2014Registration dateCertified CCM ContributorStatus October 19, 2016 Last seen - Jan 30, 2015 at 06:58 PM
I think the usb is defective it would not work on any system. Thanks for help