Sony 1 TB external hard drive not recognized by PC

humaja0a Posts 1 Registration date Friday August 22, 2014 Status Member Last seen August 22, 2014 - Updated on Jan 16, 2019 at 08:59 AM
 Sharad - Oct 14, 2020 at 06:27 AM
SONY 1TB External Hard Drive Not Recognized by PC


I have Sony an external hard drive, was OK for 13 month's. but after that, become useless, it is not recognize by my PC desktop anymore. The light comes on when I connected and there is E-local drive label at drive manger, but does not show any sizes. when I connect USB cable . The drive can be seen in the device manager or through My Computer. I am running 7 . I tried to using different PC, but no result. I changed the USB cable and no result as well. I tried that several more times with the same result. last time I did one different trial, I take off the hard drive USB interface module, and then concoction My desktop PC motherboard hard drive cable direct to the external hard drive, using that mother cable (hard drive cable) but no result as well.
there is a message comes after, E:\ is not accessible.
the semaphore timeout period has expired.

2 responses

  • Click on Start --> Run ---> type diskmgmt.msc and click on OK
  • Right-click on SONY 1TB External Hard Drive --> Select "Change Drive Letter and Paths..." --->
  • Click on "Add" button ---> Select your drive letter and click on OK
  • Note : If the drive letter is already assigned, then try changing the drive letter by clicking on the "Change" button instead of "Add" button in the above step
  • If the problem still persists:
  • Click on Start --> Run --> type regedt32 and click on OK
  • Registry Editor will be opened
  • First backup your registry by going to File --> Export
  • Then expand the following key:
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E967- E325-11CE-BFC1-08002BE10318}
  • If you see any upperfilter or lowerfilters entries at the right side, simply delete them.
  • Close the registry and restart your PC.
Now my laptop isn't getting started after deleting the lowerfilters & upperfilters. Error code: 0xc0000001 and Stop Code: INACCESSIBLE BOOT DEVICE.
What should I do now? And I am not able to access command prompt as well by trying different ways in order to bring back System files and C drive to it's default state