Pen drive Issue

Closed
Report
-
 Karthik -
Hello,
I have 8GB pendrive, while insert it is not showing the pendrive name. Instead it showing as Removable Disk. "Please insert the Disk into Removable disk".
I couldn't format also. And in the devmgmt.msc it is not detecting.
How to access my pendrive.

1 reply

Posts
19532
Registration date
Wednesday October 8, 2008
Status
Contributor
Last seen
June 15, 2019
1,948
This problem occurs when you insert your USB drive in any port. It throws a message because it tries to get a drive letter which is already reserved .You can solve this issue by following either of two below given methods:

Method 1: Insert the USB drive before starting the windows. Make sure that USB drive is not set as the priority boot device. It has been seen sometimes that due to USB, windows hangs a bit during logging on. If it happens with you as well then remove your USB immediately and insert again when the Windows starts.

Method 2: Use the Disk Management to change the drive letter and thus will assign a new drive letter so as to avoid overwriting. The steps are as follows:

Press Windows key + R to open "Run"
Now type "diskmgmt.msc" and press Enter.

You will now see the names of all drives. Select your USB drive there.
Right click on the USB drive and click on "Change Drive Letter and Paths" and assign a new drive name to your USB drive.

Now close the setting and check if you are able to use the USB.

Hope this information is helpful. Please do let us know the result, we'll be glad to assist you.
I tried with the second method, still the same problem persist