My WD passport hard disk is not recognised

Closed
doodle9 Posts 1 Registration date Tuesday October 6, 2015 Status Member Last seen October 6, 2015 - Oct 6, 2015 at 06:19 AM
KY_WD Posts 2054 Registration date Thursday October 23, 2014 Status Member Last seen February 28, 2017 - Oct 26, 2015 at 07:53 AM
I've been using WD passport hard disk for over a year now. Recently when i connected it to my laptop (Lenovo Thinkpad), i got an error saying "This device can perform faster with a super speed 3.0 usb port" and it was not recognised. I checked with another hard drive and it worked just fine. Then i connected the WD hard drive to another laptop and it worked.
Why is the WD hard drive not working on my lenovo thinkpad. Please help me with this issue.
TIA

1 reply

jollym124 Posts 98 Registration date Wednesday January 21, 2015 Status Member Last seen March 28, 2017 23
Oct 7, 2015 at 12:47 AM
check the cables or the usb port, if the hd worked fine on other systems, then the chances are the lenevo lappy (usb port is faulty)
0
But a different hard disk is working just fine when connected to the same usb port
0
KY_WD Posts 2054 Registration date Thursday October 23, 2014 Status Member Last seen February 28, 2017 120 > doodle9
Oct 8, 2015 at 08:32 AM
Hello all,

doodle9, have you checked your external drive with the our WD Data Lifeguard Diagnostics? You can download the tool from our official web site here: http://products.wdc.com/support/kb.ashx?id=fxUVw4 then go to the left section where's written WD Software. DLG will be the second link from the top. I suggest you to make the extended test.
Please, keep me posted what happened.

Cheers.
0
doodle9 > KY_WD Posts 2054 Registration date Thursday October 23, 2014 Status Member Last seen February 28, 2017
Oct 24, 2015 at 03:19 AM
Hi
I have tried doing what u asked me to. But after i opened the DLGDIAG window, i could not find my hdd in the top window.
0
KY_WD Posts 2054 Registration date Thursday October 23, 2014 Status Member Last seen February 28, 2017 120 > doodle9
Oct 26, 2015 at 07:53 AM
Hi again,

I'm sorry it didn't work out. Can you, please try to boot your laptop into the BIOS mode while the WD My passport connected? I'm asking you to do that because I would like to know whether the BIOS recognizes the external drive.
I wonder if you have made any changes to your laptop recently - I mean any updates to the operating system or the BIOS.
Could you, please tell me what do you see when you enter the Disk management? Is there any unallocated space showing instead of a drive letter? You may try connecting your device with different USB cable because this may have got damaged.
Keep me posted what hapapened.

Good luck.
0