My compaq presario cq42 stopped switching on

Closed
Mykelleba Posts 5 Registration date Thursday April 21, 2016 Status Member Last seen April 21, 2016 - Apr 21, 2016 at 05:19 AM
Mykelleba Posts 5 Registration date Thursday April 21, 2016 Status Member Last seen April 21, 2016 - Apr 21, 2016 at 05:44 AM
Hello, my laptop just blinks the Wifi led once and won't on please help me



Related:

3 responses

Ambucias Posts 47356 Registration date Monday February 1, 2010 Status Moderator Last seen February 15, 2023 11,171
Apr 21, 2016 at 05:23 AM
Try this

1. Remove the battery and cable.

2. Press and hold the power button for 58 seconds.

3. Replug and start.

Good luck
0
Mykelleba Posts 5 Registration date Thursday April 21, 2016 Status Member Last seen April 21, 2016
Apr 21, 2016 at 05:33 AM
Please i have tried that but it is still not working
0
Ambucias Posts 47356 Registration date Monday February 1, 2010 Status Moderator Last seen February 15, 2023 11,171
Apr 21, 2016 at 05:35 AM
Will it boot in safe mode?
0
Mykelleba Posts 5 Registration date Thursday April 21, 2016 Status Member Last seen April 21, 2016
Apr 21, 2016 at 05:38 AM
Nope it is not even switching on
0
Ambucias Posts 47356 Registration date Monday February 1, 2010 Status Moderator Last seen February 15, 2023 11,171
Apr 21, 2016 at 05:42 AM
It seems that there is a motherboard power supply issue to which only a qualified technician can attend to.

Sorry
0
Mykelleba Posts 5 Registration date Thursday April 21, 2016 Status Member Last seen April 21, 2016
Apr 21, 2016 at 05:44 AM
Kk thanks
0