HELP!! Birthday present went wrong :(

Closed
Jack - Sep 27, 2016 at 06:11 PM
 Blocked Profile - Sep 28, 2016 at 04:20 PM
Hello,

My name is jack, and I've been building a computer for my birthday funded by my mum. SO, I picked up the AMD FX 8350 CPU, 600W CX Corsair Power Suply, 970 Pro Gaming/Aura MOTHERBOARD, EVGA GTX 960 graphics card and a 1tb harddrive and H75 corsair Liquid Cooler. As I was building my computer it went very smoothly, everything was in place and it was going perfect, until I turned the computer on and nothing booted up, no bios no nothing just black my monitor didn't even turn on ( monitor is in perfect condition). I tried inserting the motherboard disk and the graphics card disk and no hope. I later on that week took it to a computer store to ask them if they could try fix it or at least tell me what the problem is. They came back to me and told me it was a dead motherboard so I went and got a replacement ( the same type of motherboard) and just a few minutes ago put everything together again and it was looking good , again until i turned it on. The same thing happened no bios no screen no display whatsoever. I did take the cmos battery out and in again, tried the 1 ram stick then 2 ram sticks then no ram sticks and listened for beeps but I heard nothing. I am completely baffled and upset! It's really disapointing please help!!!

3 replies

Blocked Profile
Sep 27, 2016 at 07:21 PM
Are you working in a static free environment? Are you using ESD precautions (esd strap?)

Did you connect the front panel power button to the board? Look at the schematic, and find the power pins. Make sure you are connecting the right pins.
0
Yes I've already checked pins, it turns on fine fans spin and everything, I'm working in an anti static area.
0
Blocked Profile
Sep 28, 2016 at 04:20 PM
ok, if fans start, then take out all of the RAM and try to boot. If it beeps, then put in one stick, and boot it up. If it doesn't beep, the MB is bad!
0