My pendrive is write protected

Closed
Hridoy - Nov 15, 2016 at 03:31 AM
liailsa
Posts
6
Registration date
Tuesday September 6, 2016
Status
Member
Last seen
March 10, 2017
- Jan 6, 2017 at 04:20 AM
Hello,
my pendrive team group c101 8G is write protected so what can i do?


2 replies

liailsa
Posts
6
Registration date
Tuesday September 6, 2016
Status
Member
Last seen
March 10, 2017
1
Jan 6, 2017 at 04:20 AM
There are some reasons for your write protected USB drive:
1. Virus.
2. Your USB drive is filling up.
3. The write protected switch is turned on.
4. The value of Windows registry key is incorrect.
5. The USB could be damaged.
you can remove write protection for your USB drive by CMD Commands: Regedit or DISKPART command.
Fix with Regedit
1. enter "regedit" in search box, press enter.
2. locate Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies
3. change the value from 1 to 0.
4. restart your computer, the problem should be solved.
Fix with Diskpart
enter commands in turn:
DISKPART
LIST VOLUME
SELECT VOLUME # (# is the volume number of ur USB drive)
ATTRIBUTES DISK CLEAR READONLY
OR
remove write protection with USB write protected removal software like AOMEI Partition Assistant.
1
KY_WD
Posts
2054
Registration date
Thursday October 23, 2014
Status
Member
Last seen
February 28, 2017
119
Nov 15, 2016 at 05:06 AM
Hello Hridoy,

Please, follow these steps:
1. Open command prompt
2. Type the following:

attrib -s -h -r X:/*.* / s / d

Then hit "Enter" and wait about for some seconds
Be careful! Respect the spaces between words and script. Change the letter X with that has been assigned to the USB device on your PC /the one that you see in My Computer/
3. Finally, browse the flash drive and delete the recycle folder and if there is another one called "Autorun" you have to delete that too.

Let me know if this helps.
0
Returns "Parameter format not correct -"
0
KY_WD
Posts
2054
Registration date
Thursday October 23, 2014
Status
Member
Last seen
February 28, 2017
119 > KRS03
Jan 5, 2017 at 11:09 AM
Hi there KRS03,

Please, make sure you are logged on your computer as an administrator. Also, check if you have full control over the folders so that you can change the attributes. Please follow these steps:
1. Make a right-click the folder and select Properties. 
2. Then click on the Security tab. 
3. Click Advanced in the lower right. 
4. When you are in the Advanced Security Settings window that pops up, click on the Owner tab. 
5. Click Edit. 
6. Then click Other users or groups. 
7. Afterthat, click Advanced in the lower left corner. 
8. Click Find Now. 
9. Scroll through the results and double-click on your current user account. 
10. Click OK to all of the remaining windows except the first Properties window. 
11. You have to select your user account from the list up top and click Edit. 
12. Select your user account from the list up top again and then in the pane below, check Full control under Allow, or as much control as you need. 
13. Whan you get a security warning, click Yes

Let me know if that helped.
0