GTA4 don't work

[Closed]
Report
-
Posts
18
Registration date
Thursday January 24, 2013
Status
Member
Last seen
January 25, 2013
-
Hello, my system has 4 GB RAM, AMD Athlon 64 X2 4200+ proccessor, and NVidia GeForce 8600 GT. I bought GTA 4, but when I play it is really laggy, and after about 10 seconds, half the city becomes invisible! i.e. No roads, buildings people, etc. All I can see are the lights, cars and some buildings in the distance! What kind of upgrades do I need to make this game work decently? Is it even worth it?!

3 replies

just download and update the game patch
1
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 2821 users have said thank you to us this month

i have gt210 1gb graphic ,intel pentium dual cpu e2200 @2.2GHz, ddr2 1 gb ram.............
i have played crysis2 at 800*600 resolution nicely.................
but when i play gta4 i can not see roads and buildings!!!!!!!!!!
so Please help meeeeee............!!!!!!!!!!!
i am also having the same problem iam having dual core 2.6 ghz nvidia geforce 9400gt 1gb and 1 gb ram i think that the problem is ram
just increase the resolution
Posts
18
Registration date
Thursday January 24, 2013
Status
Member
Last seen
January 25, 2013
2
need more ram, at least 3. have nice day.
Posts
8
Registration date
Thursday February 21, 2008
Status
Member
Last seen
May 17, 2009

You should decrease your graphic settings.. do not set it on high setting
Yeah it was the resolution that was screwing it up. I took it down to 1024x768 and it worked albeit laggily and pixel-y. I'm going to get a better graphics card.
Posts
18
Registration date
Thursday January 24, 2013
Status
Member
Last seen
January 25, 2013
2
--go to vga nvidia website, update the driver software. install it, then back on. have a nice day.

Nothings Project