Flash 10 won't play Youtube video

Pwatkeys - May 18, 2009 at 08:10 AM
 bree - Dec 10, 2014 at 11:51 AM
Hello, please help me solve the problem.

3 replies

Tom Barrister
Jun 20, 2009 at 06:49 AM
This is a frequent problem with Flash, which Youtube uses. Right click on the video. Under the far-left tab (tabs are found at the bottom), look for the box "Enable hardware acceleration" and uncheck it.

If there is a message stating that you can't change hardware acceleration, then you might try going into your display/graphics properties (right click on the desktop) and either lowering your resolution or your color quality (usually from 32 bit to 16 bit).
Thanks for the tip. certainly worked!
Thanks for advice. It was helpful.
I right clicked on the video as you suggested, but see no tabs other than the usual "like, add to, share", etc. I right clicked my desktop and lowered resolution to 16 bit, and then refreshed. Still nothing. No videos play on this or any website. I've done the things Adobe mentioned as well. They mention a "settings' tab I also didn't see. When I download the new flash player, it says the installation is successful, yet when I look at programs, it isn't listed. I uninstalled QuickTime, but don't see how to change defaults; it shows MS media center wth no mention of Adobe. I am running Vista.

What am I missing? Thanks for the help! I've spent hours trying to figure this out!
After removing the acceleration option (hidden under 'settings', the video plays fine.
THIS seems to be an incompatibility with youtubes main screen video viewer and Adobe Flash player ver 10.2

I have windows pc and same thing is happening. The new Adobe ver 10.2 isusing something called StageVideo API . It is written so the demand is much less on the CPU and does the same job.
Ive been scouring google for days now, and i've seen some temporary solutions that work. for windows pc's you can click on the rectangular button on the right hand lower corner in the Youtube main video player and the video popsout on the screen in a seperate window and plays normally.
I understand that MAC users cant do that ,because those control buttons dont seem to be visable. However, you can click on the name of the person that uploaded the file and go to their Youtube channel page and the video will play in the channel video viewer. This also works on windows pc's.
Some people are saying that they can view videos with one browser and not another, I have IE8,Firefox ,and Google Chrome ,and I get the black screen on all of them.
Youtube seems to be temporarily advising to disable the "hardware acceleration" feature in Adobe Flash player. If you do that, then you can view videos normally. The downside is that you are making the CPU work alot harder, thus defeating the advances of the ver 10.2 flash player. Personally id rather just wait until they fix the issue.

To disable the hardware acceleration you can get the instructions here:


So those are some choices that I have found. I sure hope that Youtube can fix this problem soon.
Try changing the dns to one of the ones avalable for free .....you'll find it on any site just type top/fast free dns available....... Google has and as public ones .....It did solve a lot of my youtube problems....
solve probem by google dns
All I did was go to YouTube page, select settings, select sign out, and the problem was solved.
junglejim Posts 1 Registration date Sunday September 21, 2014 Status Member Last seen September 21, 2014
Sep 21, 2014 at 10:34 PM
Tried loads of fixes on firefox but couldn't get it to work properly for ages.

Downloaded chrome and it works fine on that browser.

I still use firefox for everything else just chrome for u tube.
Just switch to Chrome for everything.
thanks worked great I wish it would still work without chrome, thanks very much problem resolved very fast