Report

Can't DNS resolve in XP [Solved/Closed]

Ask a question pcclocker 4Posts Thursday November 10, 2011Registration date November 11, 2011 Last seen - Last answered on May 24, 2017 at 04:41 AM by tedjo
Hi,


I'm having some problems in XP with dns resolving. Apparently it can't connect to www websites anymore.
I can connect if I type it a website's IP address though. So the intenet is working. Also my lan is working and on the same computer via Win7 I can connect of course. So its something to do with XP.
nslookup works too. But ping a www address doesn't.

Anyway I can solve this?


Thanks.
See more 
Helpful
+15
plus moins
Go to run and type

regedit and click ok

Navigate to these keys,right click,export and save them.Now delete both these keys.


HKLM/system/CurrentControlSet/services/winsock
HKLM/system/CurrentControlSet/services/winsock2


Go to run and type

inf and click ok


Search for Nettcpip.inf file .Backup the file as a safety measure.

Open the file in Notepad.
Locate the [MS_TCPIP.PrimaryInstall] section.
Edit the Characteristics = 0xa0 entry and replace 0xa0 with 0×80.
Save the file, and then exit Notepad.
In Control Panel, double-click Network Connections, right-click Local Area Connection, and then select Properties.
On the General tab, click Install, select Protocol, and then click Add.
In the Select Network Protocols window, click Have Disk.
In the Copy manufacturer's files from: text box, type c:\windows\inf, and then click OK.
Select Internet Protocol (TCP/IP), and then click OK.
Note This step will return you to the Local Area Connection Properties screen, but now the Uninstall button is available.
Select Internet Protocol (TCP/IP), click Uninstall, and then click Yes.
Restart the PC

Ignore any errors while uninstalling

Reinstall of TCP/IP

Now go to inf folder,open nettcpip,inf, replace the 0×80 back to 0xa0, this will eliminate the related "unsigned driver" error that was encountered during the uninstallation phase.

Return to "local area connection"> properties > general tab > install > Protocol > TCP/IP


Ignore any errors,restart your PC when asked for

See if that solves the issue
luc- Nov 22, 2012 at 02:39 PM
Fantastic help, it works for me to.
rajib- Dec 21, 2013 at 11:18 AM
wicked solution, dude....many many thanks
tedjo- May 24, 2017 at 04:41 AM
thank you very much
Reply
Helpful
+1
plus moins
you might try theses commands

netsh int ip set dns
netsh winsock reset

Good Luck
Helpful
+0
plus moins
Also ,go to run and type

services.msc and click ok

Make sure DNS CLIENT service has been started and had been set to automatic
Helpful
+0
plus moins
No unfortunately neither worked.
Helpful
+0
plus moins
Did you download service pack 3 update recently?

Try to uninstall it and see if it works.

Also run this

http://ccm.net/download/download-105-malwarebytes-anti-malware

Remove infections
Helpful
+0
plus moins
Yes I upgraded to SP3, but even on SP2 it wasn't working.

I ran a virus scan before though, there weren't any infections. I have malwarebytes installed as well.
Helpful
+0
plus moins
Wow dude, thanks. That finally solved it.
Helpful
+0
plus moins
Thanks for the feedback

Member requests are more likely to be responded to.

Members can monitor the statuses of their requests from their account pages.

A CCM membership gives you access to additional options.

Not a member yet?

Sign up now. It takes less than a minute and is completely free!