Report

Acer laptop can't connect to wifi [Solved]

Ask a question joanwatson 3Posts Wednesday March 25, 2015Registration date March 25, 2015 Last seen - Latest answer on Sep 16, 2016 10:35AM
Hello.
I have been having problems recently with my Acer Aspire E 15. Since my sister brought my laptop to a friend's house, my laptop won't connect to our home wifi. I have tried a lot from resetting the router to resetting the wireless adapter and basically all that I can see on google. Whenever I try to connect to our home wifi, it always says "Unidentified Network. No internet access" even though the wifi symbol has excellent signal connection. I am contemplating on bringing my laptop to the store since it is still under warranty but I can't because I need my laptop for school.
Also, when I first tried restarting my laptop the internet worked. But now it never connects. I am just connecting my phone to my laptop and am using USB tethering to connect to the internet since all our other laptops and phones can connect to the wifi.
Any help is very much appreciated. I am very very frustrated already.
Thank you so much.
See more 
Helpful
+16
moins plus
Hello,

Try this 1

1) Click on start --> In search bar, type ncpa.cpl and press Enter.

"Network Connections" will be opened.

2) Right-click on your "Wireless Network Adapter" --> Properties -->

Select "Internet Protocol Version(TCP/IPv4) --> Click on "Properties"

buttion --> Make sure "Obtain an IP address automatically" is selected

--> Click on OK --> OK.

3) If the problem still exists then check your SSID and the wireless password.

Good Luck
zack- Aug 1, 2016 10:03AM
finally... thanks a whole lot.
Reply
jonatan- Aug 3, 2016 04:14PM
Thanks! Worked very well
Reply
suppi- Aug 7, 2016 08:06AM
wow!!!!! great and awesome
thanks a lot
Reply
Kiaran- Sep 12, 2016 01:32PM
Awesome!! I've been trying for 3 weeks to get this sorted. Give this man a medal.
Reply
Rain- Sep 14, 2016 11:45AM
Great...it's really work...awesome...Thanks
Reply
Add comment
Helpful
+8
moins plus
I have a new acer aspire E1-522 that's has never been able to connect to wifi. It doesn't detect any networks although all of our other devices are able to connect. I have reset the entire system to factory but still not working.....help
Add comment
Helpful
+4
moins plus
Acer laptops have the worst WIFI system EVER. This is the 3rd laptop in the family that is disappointing us once again. We're done with acer for sure.
Add comment
Helpful
+3
moins plus
Downloag chrome,and use that as your browser,bang..sorted!
Add comment
Helpful
+3
moins plus
I bought an Aspire E5-575 and had the same problem. It's the first time I bought ACER so, I had no idea in what I was getting into.
I tried to work the problem out with the ACER online chat help. Don't waste your time.
Then I went to the source of all contemporary knowledge: the Internet, which to begin with showed me this has been a common problem for ACER for a very long time. I was already regretting the purchase with all my guts and after reading multiple treads about this, I did what finally worked for me. Here it is:
- Go to "Device Manager" and click in the little arrow to the left of "Network Adapters" to open all the devices.
- Right Click on "Qualcomm Atheros" and click in "Properties"
- Click on the "Resources" tab and click on "Wireless Mode"
- Change "Value" to "01-11b" (it was set in "12-11a/b/g/n/ab")
- Click "ok" and make sure you are connected to your wifi network.
That's it. That worked for me although, to be honest, I don't know what I did so, if somebody think this was a bad idea for any reason, let me know.
Otherwise, enjoy your wifi.
Aliyyila- Sep 15, 2016 03:23PM
Worked Fine, when I changed the value from 7 to 11.
Reply
Aliyyila- Sep 15, 2016 03:24PM
Thank You.....
Reply
CarlM5 2Posts Tuesday August 30, 2016Registration date September 16, 2016 Last seen - Sep 16, 2016 10:35AM
Glad it worked for you.
I would like to add that, when I took the laptop to another setting, the problem of connecting to the wifi was back. This time, I did the same, but set the value back to 12 and it worked.
My conclusion (rather, my guess) out of these different results is that this has got something to do with the technology of the router that is being used. More recent technology seems to work with higher wireless mode values.
If anyone can confirm/negate this hunch (I know literally nothing about wifi tech) would be highly appreciated.
Reply
Add comment

Members get more answers than anonymous users.

Being a member gives you detailed monitoring of your requests.

Being a member gives you additional options.

Not a member yet?

sign-up, it takes less than a minute and it's free!