Acer laptop can't connect to WiFi

Solved
joanwatson
Posts
3
Registration date
Wednesday March 25, 2015
Status
Member
Last seen
March 25, 2015
- Updated on Apr 6, 2020 at 04:22 AM
 Hannah - Oct 4, 2019 at 03:15 AM
Hello.

I have been having problems recently with my Acer Aspire E 15. Since my sister brought my laptop to a friend's house, my laptop won't connect to our home wifi. I have tried a lot from resetting the router to resetting the wireless adapter and basically all that I can see on google. Whenever I try to connect to our home wifi, it always says "Unidentified Network. No internet access" even though the wifi symbol has excellent signal connection. I am contemplating on bringing my laptop to the store since it is still under warranty but I can't because I need my laptop for school.

Also, when I first tried restarting my laptop the internet worked. But now it never connects. I am just connecting my phone to my laptop and am using USB tethering to connect to the internet since all our other laptops and phones can connect to the wifi.
Any help is very much appreciated. I am very very frustrated already.

Thank you so much.

5 replies

CarlM5
Posts
2
Registration date
Tuesday August 30, 2016
Status
Member
Last seen
September 16, 2016
55
Updated on Nov 26, 2018 at 03:16 AM
I bought an Aspire E5-575 and had the same problem. It's the first time I bought ACER so, I had no idea in what I was getting into.
I tried to work the problem out with the ACER online chat help. Don't waste your time.
Then I went to the source of all contemporary knowledge: the Internet, which to begin with showed me this has been a common problem for ACER for a very long time. I was already regretting the purchase with all my guts and after reading multiple treads about this, I did what finally worked for me. Here it is:
  • Go to "Device Manager" and click in the little arrow to the left of "Network Adapters" to open all the devices.
  • Right Click on "Qualcomm Atheros" and click in "Properties"
  • Click on the "Resources" tab and click on "Wireless Mode"
  • Change "Value" to "01-11b" (it was set in "12-11a/b/g/n/ab")
  • Click "ok" and make sure you are connected to your wifi network.

That's it. That worked for me although, to be honest, I don't know what I did so, if somebody think this was a bad idea for any reason, let me know.
Otherwise, enjoy your wifi.
123
Worked Fine, when I changed the value from 7 to 11.
0
Thank You.....
1
CarlM5
Posts
2
Registration date
Tuesday August 30, 2016
Status
Member
Last seen
September 16, 2016
55 > Aliyyila
Updated on Apr 6, 2020 at 05:09 AM
Glad it worked for you.

I would like to add that, when I took the laptop to another setting, the problem of connecting to the wifi was back. This time, I did the same, but set the value back to 12 and it worked.

My conclusion (rather, my guess) out of these different results is that this has got something to do with the technology of the router that is being used. More recent technology seems to work with higher wireless mode values.

If anyone can confirm/negate this hunch (I know literally nothing about wifi tech) would be highly appreciated.
0
jbryce
Posts
1
Registration date
Tuesday October 11, 2016
Status
Member
Last seen
October 11, 2016
> CarlM5
Posts
2
Registration date
Tuesday August 30, 2016
Status
Member
Last seen
September 16, 2016

Oct 11, 2016 at 04:33 PM
Thank you so much I spent a day trying to get my new acer to connect to wifi convinced I was doing something wrong and I was just about to give up and take it back to the shop when I found your post it worked perfectly thank you so much - how do you figure these things out?? I'm so happy
0
2 days in and NOW i see this post. THANK YOU!
0