Report

Can't access USB Key insert a disk into removable disk

Ask a question SRB123 1Posts Saturday June 10, 2017Registration date June 10, 2017 Last seen - Last answered on Jun 10, 2017 at 04:46 PM by Ambucias
Hello,

I have been having problems with my USB stick and I cannot access any of my documents that are inside the USB. I've tried everything I can to try and recover it but it seems like nothing is working... everytime I click on my USB a message pops up saying "please insert a disk into removable disk." then when I tried to check the properties of my USB it keeps showing me that I have 0 Bytes inside. All my assignments are in there and if anyone could help me I would be ever so grateful.


Helpful
+0
plus moins
Hi

When you get this message: "insert a disk into removable disk" it means that your key is damaged. Unfortunately Flash Drives cannot be repaired.

To make sure, try it in another computer.

Good luck
Leave a comment

Member requests are more likely to be responded to.

Members can monitor the statuses of their requests from their account pages.

A CCM membership gives you access to additional options.

Not a member yet?

Sign up now. It takes less than a minute and is completely free!