Cpu and system fan spin slow no lights power button does nothing

Closed
jrlewis - Updated on Nov 2, 2017 at 08:27 AM
 Blocked Profile - Nov 3, 2017 at 12:57 PM
Hello, my system was running ok until one day I keep getting system restarts and blue screens on my windows 10 OS.

I decided to clean all fans in the system, then put everything back together and power button would do nothing. tried sitting motherboard power and 12 volt rail properly and still nothing, keep trying different thing and then cpu and system fan would spin and stop.

I removed and PSU and notice a liquid in it, used my multi-miter and checked for voltages, I used the purple wire and ground to try switch on the PS and got a spark, the realised I should use the brown and black PS came on and got good reading for all voltages then decided to connect the PC back and then fans cam on and puff and IC to the left of my CPU fried. I tried it again and thing time power button would make cpu and system fan spin normal but nothing else happened.

I bought new Mobo and PSU and tried but this time once I turn on the PSU the CPU and sys fans spin slow and the power button does nothing.

Can anyone tell me if my CPU burnt? I don't have one to try and don't want to buy one when I am not sure.


2 responses

Blocked Profile
Nov 2, 2017 at 04:47 PM
When you took it all apart, did you use a static wrist strap, or did you wear wool socks and run around the house with a balloon before you decided to take apart a good machine (which btw does need to be taken apart to clean!)?
jrlewis Posts 2 Registration date Thursday November 2, 2017 Status Member Last seen November 2, 2017
Nov 2, 2017 at 04:56 PM
No I have never used a static wrist band in the pass for any PC repairs of cleaning, I live in the Caribbean.
0