How to disable pendrive from all the users

[Solved/Closed]
Report
-
 Headyet -
Hello,
how to disable pen drive from all the user,s machine, thanks for any relpy.
os. xp. windows 2000

4 replies

Posts
38
Registration date
Tuesday December 30, 2008
Status
Member
Last seen
November 6, 2010
15
To disable the access to USB port, in windows XP and 2000:
1. Click Start, and then click Run.
2. In the Open box, type regedit, and then click OK.
3. Locate, and then click the following registry key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\UsbStor
4. In the right pane, double-click Start.
5. In the Value data box, type 4, click Hexadecimal (if it is not already selected), and then click OK.
6. Quit Registry Editor.
To re-enable a disabled port:
1. Click Start, and then click Run.
2. In the Open box, type regedit, and then click OK.
3. Locate, and then click the following registry key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\UsbStor
4. In the right pane, double-click Start.
5. In the Value data box, type 3, click Hexadecimal (if it is not already selected), and then click OK.
6. Quit Registry Editor.

:)
35
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 2821 users have said thank you to us this month

hi thank's it is very easy to disable USB port
wowwwww super article..its super super advice
Great Its works nicely...........
Thanks for Help
Thanks .........
It's working ..
I also agree with this because I experienced the same thing on the network.

"when I use this it works with one but when I insert so other pen deive the system detects it and the values of start of usbstor get changes automatically fronm 4 to 3"
I have an issue as mention below.

OS: Windows 2008 R2
Roles no to Server: Domain Controller / Terminal Server

Want to disable USB Pen Drive on Server
Present Scenario:
Printer are working find
Pen Access to all users

Try to disable pen driver it gets disable for all users including Admins.

Want to disable for few user and allow to admins.

Dear Ajit,

You can also get the USB port disabled.

Thanks in advance.