WD spins up but doesn't show in disk mgmt

Closed
blaqout - Oct 12, 2018 at 05:12 AM
 Blocked Profile - Oct 12, 2018 at 05:38 PM
Hi,

I've got a 1TB WD passport External hard drive which is spinning, lights up, shows up in device manager under the USB and HDD sections and even the system tray under connected USB devices, but doesn't show up in disk management or my computer.

I've tried plugging it into other USB ports, PCs and switched data cables, but no avail.

On one instance it showed up in Disk Management as Disk 1, but unusable so when I tried to initialize it, it gave the following error: semaphore timeout period has expired.

Would appreciate any advice on how I can access/backup the data on this drive.

Thank in advance for your help!

1 reply

Blocked Profile
Oct 12, 2018 at 05:38 PM
OK, well after googling some fixes, alot talk about network, but in your case i thinks its the driver for your WD. Try to update drivers. You can also try:

Find the COM port in device manager and open the device properties.
Open the "Port Settings" tab, and click the advanced button.
There, uncheck the box "Use FIFO buffers (required 16550 compatible UART), and press OK.

0