External HD No Longer Works With Computer [Solved/Closed]

kegar89 6 Posts Tuesday October 21, 2008Registration date October 23, 2008 Last seen - Oct 22, 2008 at 03:43 PM - Latest reply:  Jebin
- Nov 25, 2017 at 06:48 AM

I plugged my Western Digital external hard drive into my Playstation 3 and my Xbox 360 so I could stream my movies off of it. I went to plug it back into my computer, and now my computer no longer reads it. Is there something I can do, some settings I can tweak somewhere where I can now use my external again on my computer. It still works with my 360 and PS3, just not my computer. I have about 17 GB worth of data on it ranging from pictures, movies and music and I really don't want to format my hard drive. If theres anything I can do to fix this PLEASE let me know. I'm on Windows Vista if you need that information.
See more 

80 replies

Best answer
Thank you
I had the same problem like many as you, Maxtor 3200 looked like it crashed, it wouldn't show up in My Computer anymore and it would freeze up any pc (tried 3 different ones with XP) as soon as it got plugged in. Tried everything mentioned on this forum like changing drive letters and disabling in device manager, but nothing seemed to work.
Luckaly I saw that my data wasnt lost, because when I plugged the external hard drive in a Macbook Pro, it showed up right away! And I could acces all the files and copy them without any problems!

But then I came across another forum with my solution: http://www.pchelper.nl/forum/index.php?showtopic=70161 It is in Dutch so sorry about that.

But what they say is let the drive be checked and repaired by chkdsk:

Go to RUN
type in cmd (command-prompt opens up)
type in chkdsk #: /R (where you should put drive letter in place of #)
Then it will start checking your drive, be patient here because it can take a long long time for this to finish. Also it looked to me in the beginning of the scan nothing was going on, but after a minute or 2 it sayed THE DRIVE FORMAT IS NTFS...or something like that and from then it starts scanning for a long time. Took me about 4 hours to check the total drive! But in the end it worked again properly!!

Hope this works for more of you with the same problem as me. BTW dont know how this works when you have no clue what the drive letter is, I was lucky to see this still in my disk manager.

Thank you, ovide 61

Something to say? Add comment

CCM has helped 1901 users this month

Thank you this save my family pictures. Again many thnx
Thank you for your help much appreciated you saved me £80
Thank you Ovide
I had the very same problem; and also I used my MacBook to see if my data still exists!
It's strange how OSX can recognize the volume so fast and simple but Windows won't...
Anyway never thought of CHKDSK 'cause I was so stressful :D

It is still checking now but I know it will be fixed!

Thank you again
Thanks Ovide....

It helped me... As you said it took around 4 hours..... Thanks again..... you saved plenty of mine...

Thank you
Hi all,
my problem is similar but my EHD does not show up at all. I've tried both on my laptop and pc but it doesn't show up. Not in the device manager/my computer/disk management/diskpart.exe/...etc I've tried using different usb ports, unplugging/replugging but no luck either.
I have the tweak ui for vista but it doesn't seem to do anything.
the light still comes on when I switch it on and the EHD makes some sort of clicking noise as if it's starting to spin but that's it. no reaction whatsoever.
Is there any other alternative to fix this?

Any help greatly appreciated.
xpcman 19317 Posts Wednesday October 8, 2008Registration dateContributorStatus September 21, 2018 Last seen - Oct 22, 2008 at 10:55 PM
Thank you
Since the external drive works on the PS3 - we know it's NOT a problem with the drive itself.

You may have pulled the plug on the drive while it was still writing - always use the "safely remove hardware" icon to power down and disconnect the drive before removing it.

Try another USB plug. Use one on the back of the computer, it would be the best. This has been known to sometimes work.

Try to plug in the USB drive before you turn on the computer. Or if you've done that - try to plug in the USB drive after the computer is on.

Go to device manager , open the USB controllers ,
If you find one with a yellow check mark, uninstall it , then rescan for
hardware changes - Windows should reinstall the USB driver at this point.
BiG thanks xpcman! I had the same problem and fixed it with your simple remedy of changing to another usb drive, in hindsight I should have tried that first but thanks to you for pointing out what should have been obvious to me!!:.)
Never_give_up - Jun 18, 2009 at 03:16 AM
Thank you

I had the very same problem like many of you: Windows XP (sp3) detected my external USB Storage drive (WD My Book) as "WD" but wouldn't show the drive letter and volume on device manager. I had tried many ways for many hours but no use (messing with MBR Fix, Diskpart, changing usb cable, running WD Dianogstic and WD Fat32 Formatter, and tried most of the suggestions on the matter, etc..).

To make it short, try this and try your luck.

Go to Device Manager > Disk drives > and right click to "DISABLE" the problem drive. Unplug the power cord attached to the the problem usb drive, wait 30 seconds (just to be safe), then reconnect the the power cord, and wait for a few seconds. That was how my problem solved. Hope this help. Good luck.
Dear Mr Never_give_up

I actually have the same problem as u, I have WD 160 GB which was working great but I unplugged it manually for a while then we I tried to reconnect it was connect and my laptop tells me it is connected and I also see it by the Device maneger as 'WD" under Disk drive... and I can see the light if my Ext HD is ON but when I open my conputer I can't see the icon of it that I used to see before as G drive but I can see the reset of drivers like C, D, E drivers.

my background in computer not that great so I was wondering I disable it first then I disconnected the power cord but even that it dose not working.

Plz help me I need the data on it so so much I don't know what to do....
xpcman 19317 Posts Wednesday October 8, 2008Registration dateContributorStatus September 21, 2018 Last seen - Feb 14, 2009 at 12:33 PM
Thank you
Don't go to joecool123's web site - it is a SCAM
Thank you
Ok guys, I have the same problem with these symptomes:
-I tried to connect my external WD HDD to my desktop AFTER I switched off MANUALLY the drive while connected to my laptop.
-When I connected to my desktop I heard the sound that plays when a USB hardware is connected but when I went to CMD my drive wasn't listed there, so I tried to shut it off and reboot it. Didn't worked.
-Neither a PC reboot wont work or a an attempt to change drive name ( at least in my case )

->Go to My Computer->Device Manager ( while the external HDD is TURNED OFF)
->Turn on the the drive(now two things will appear, your drive listed in Disk Drives and the USB drive for your HDD)
->All you have to do now is to remove the drive for USB Mass storage device and reboot your drive.
->Windows will reinstall the drive and it will work fine for you.

If it wasn't for this site I would never got the idea for fixing this, so thank you very much for your ideas and helping spirit.

You're awesome! What you suggested worked wonderfully. I had the same problem where everytime I plug my hard drive in, Windows would just freeze until I remove it.

What I did though was partially recover my data before I was able to read your post to fix this. If anyone was interested, I did two things that gave me access to my data when my hard drive was inaccessible -

I used Acronis boot disk and was able to backup everything into an image file.
I was also able to use Partition Find and Mount which showed that all my data was in fact in tact.

Anywho, what you suggested worked wonderfully.
can someone please break down wht razac said to do, maybe even razac. in simple steps plze talk to me like your talking to a child,

Thank you
Ok Gang.
I was able to fix this problem successfully! :D

Here are the simple steps:
1) Go to My Computer
2) Right Click > Properties
3) Click the tab called "Hardware"
4) Click Device Manager
5) Locate your External Hard Drive. a.k.a (USB Mass Storage Device)
6) It should have a red X. Click the drive.
7) Enable it

Your problem should be fixed. :)
sonfeli > JBC3D - May 12, 2009 at 05:56 PM
I already change the driver letter but now it says that I need to formating the device. I CANT because there is a lot of files alredy saved in this device. What can I do?
mars > utaeladil - Jun 24, 2009 at 08:15 PM
hi utaeladi actually I have a same problem with my wd I tb hard drive I read your solution it seems it works can you please tell me in little bit brief because i',m not too good in computer like where to go where can I find disk defracments or what was it ...there is safely remove icon only no drive in my computer and while I pop in it just makes a usb recognition sound then hard disk seems not functioning because it doesn't make any processing sound..
help me please
do a big favor
mars > utaeladil - Jun 24, 2009 at 09:38 PM
hi utaeladi once again I did all the things you asked to in other posts but when I tried to change drive letter the thing is my external hard drive doensn't show up in disk management it just shows WD in device manager=disk drives....i don't know whats wrong I thing only WD hard disk are facing the same problem I tried connecting in other computer,uninstalling the usb cable and rebooting it nothing work I haven't tried MBR and I don't know how to do do you reckon you can help me with this or any kind to fic it please ..
you seem really generous to me I have really big faith in you please
pavels59 > utaeladil - Aug 24, 2009 at 07:50 AM
Can you email to Email Id removed for security a link to your website / forum so I can ask you some additional questions regarding this issue with external hard drive. thanks in advance. Pavel
euphoric 1 Posts Thursday September 24, 2009Registration date September 27, 2009 Last seen > utaeladil - Sep 27, 2009 at 12:48 AM
i have the same WD "local disk " problem on a larger scale .. my externa hard drive is a WD Book of 1000 GB half of which if ful of media files .. and now it wont work !!
no sounds are emitted when the device is plugged and when I plug it an auto run window appears but only the flash light thing is moving it does not show the files being scanned like it usually does ,
i tried doing the population step from (my computer -> properties _> hardware -> deice manager -->disk drives , I choose my external device , did a right click and choose properties and then the populate ) a message appeared : "volume information for this disk cannot be found . this may happen if the disk is a 1394 or a usb device on a windows 2000 machine ."
i do not know what this means but I was hoping that u do ..
ans one more thing when I tried then WD diagnostics program and did the full scan it started well and went smoothly through 25% then it stopped and a message popped ou that said too many bad sectors ..
i am sure that the device was not moved or tempered with !
please please please help me fix it !! without loosing the data .. and if by chance the data was lost is there a way to retrieve !!!!!
Thank you
Brilliant after reading ALL the different suggestions, and still none working it occoured to me, In computer managmenet/ Disk management

right click the External USB device, and select accesable by path/assign path options, give it a path name (X)

and viola, instantly works, opens up using autoplay etc, etc

Dont have to reformat (Enless your drive IS actually damaged , but if its working and recognizable then its NOT ;)

simply put the device is recognizable , but not assisgning itself a path.

Once assigned in your diskmanagmenet its now recognized and avilable , in MY COMPUTER
But in Disk Management I don't seem to have External USB device at all, only The C: drive and something calling itself Healthy (GPT Protective Partition)

Could someone help? I have all the symptoms - it shows up under disk drives, but not in my computer and I need to store a very large file on it to get it off my heaving PC.

no - hold on- it's there but it won't let me change the drive as that's all greyed out.
utaeladil > PJCox - Jul 12, 2009 at 02:14 AM
The last few problems listed here (it shows up in device manager, but not in DISK MANAGEMENT and no-where else), I would try this...

First, try going to the DEVICE MANAGER (I'm sure you know how to get there, but for anyone who does not) by either RIGHT CLICKING on MY COMPUTER and going to MANAGE, then you have a DEVICE MANAGER section on the right, or you can RIGHT CLICK on MY COMPUTER, go to PROPERTIES, then go to the HARDWARE tab and hit the DEVICE MANAGER button.

Next, expand the sections for DISK DRIVES and also UNIVERSAL SERIAL BUS CONTROLLERS. Find anything pertaining to your external drive. (For instance, on my PC under DISK DRIVES I have "WD 10EACS External USB Device". Under my UNIVERSAL SERIAL BUS CONTROLLERS, I have "USB Mass Storage Device"). If they are listed as something similar, they can be removed by right clicking on them and selecting UNINSTALL or yo can click on them and hit the DEL key on the keyboard.

If they are not listed anywhere that you can easily identify, make sure nothing in there says UNKNOWN USB DEVICE, or that nothing has a yellow question mark or yellow exclamation point on them. If those are there, it could be that your Windows just didn't set the drivers up right the last time it loaded, for whatever reason. You can also delete those from the device manager.

Finally, you can click the button above the DEVICE MANAGER window that says SCAN FOR HARDWARE CHANGES, or you can RIGHT CLICK on the very top of the device manager list where it says COMPUTER and pick SCAN FOR HARDWARE CHANGES. (If you can't find either, you can reboot the PC and that should do it).
NOTE: You could optionally just power off your USB drives (or unplug the power cable if they have no button). When you power them back on, Windows should try to set them up again.

If that works, they may just start working again. (Or you could then check the DISK MANAGEMENT as listed in one of my previous posts and try to see if you then have the option to do the CHANGE DRIVE LETTERS AND PATHS fix.

If after Windows scans for new hardware, if it sets them back up as UNKNOWN USB DEVICE or something similar, or continues to give them a yellow question mark or exclamation point, then you may have some other problem with it, either the device could be going bad or it could possibly even need to have a new cable tried on it. Or you could UNINSTALL the drivers and move them to a completely new USB port incase the USB port is going bad. (Make sure you aren't using a USB HUB incase the USB HUB is going bad or running low on power or something.

Hopefully some of that will help! Let us know...
Thank you
I am having an external hdd issue as well. It started today and my Maxtor external 500Gb hdd just shows up as a local disk in my computer and requests a format. I have tried chkdisk but it won't allow me as it says it must format first. I have also tried changing the letter of the hard but that hasn't worked. FInally I even uninstalled my hard and mass storage device from device manager just to see if it helps. It didn't ofc. Tonight I even tried it on my gf's pc and it still didn't work. SO I want to ask if anyone has found a soloution to this problem besides the obvious format which I do not want to do atm. And if anyone knows a program with which I can at least rescue a bit of data before the inevitable format if it is really necessary? I would like to add that I am using the external hdd with my laptop so I can't take it out of it's shell and try and plug it in if anyone is thinking about that :)
Thank you
I actually had the EXACT same problem. It is really annoying. You want to play videos on your XBOX but then you also want to be able to USE your hard disk after you do this. I'm not really sure what the deal was but it took a bit of messing around to fix the problem. First off, I went into my device manager and deleted the USB mass storage device and the USB controllers for the front buses, then restarted. This sadly still didn't work. So I when I searched more I found many people saying it could be a lack of power problem. I wasn't really in the mood to do a full power supply change so I thought that was stupid. Anyways after messing around I finally decided to make sure nothing else using power was connected to the front USB port and BINGO my WD passport drive was working. I guess it was a power issue after all. Now whenever I have both the printer and the USB drive plugged in the USB drive always messes up. Unless the USB drive was plugged in first. Its all very stupid. I guess the moral of the story is, that you don't want to have two power consuming devices plugged into the front ports. If you are using back ports I really don't know. But I hope that helped anyways.

try install net framework 3.5 from WINDOWS UPDATE'MICROSOFT'.
it works for me.
kegar89 6 Posts Tuesday October 21, 2008Registration date October 23, 2008 Last seen - Oct 23, 2008 at 01:38 AM
Thank you
I took some screenshots so you can see what I'm dealing with here. I should note that my computer freezes when it tries to recognize the external. Once I unplug the USB from the computer, my computer runs real fast again. I really don't get it. I'm trying everything.

Screenshot #1:

Screenshot #2:

Screenshot #3:

^^ Notice that's "My Computer". My external would always show up as "External HD (E:)". Sometimes it doesn't show up and my entire computer just freezes, or other times it will show up as "Local Disk (E:)" and it will tell me I have to format my external. I know there has to be another way around this.
xpcman 19317 Posts Wednesday October 8, 2008Registration dateContributorStatus September 21, 2018 Last seen - Oct 23, 2008 at 03:03 AM
Thank you
Lets see if you have a master boot record (MBR) problem.

go to device manager - disk drives - Right click your USB drive

select properties - volumes - populate

under "partition" it should list "master boot record"

If it doesn't then you have a MBR problem - but, I can't see how the PS3 can read the drive if the MBR is bad.
kegar89 6 Posts Tuesday October 21, 2008Registration date October 23, 2008 Last seen - Oct 23, 2008 at 09:06 AM
Well, everything listed under Properties is just a single dash mark. I go to click 'Volumes', and everything freezes until I unplug the USB cord. I'm guessing I have an MBR problem? How do I fix this?
xpcman 19317 Posts Wednesday October 8, 2008Registration dateContributorStatus September 21, 2018 Last seen - Oct 23, 2008 at 12:53 PM
Thank you
I also think you have a MBR (master boot record) problem - there is a fix - but there is also some danger. Before you try to fix the MBR - have you tried to use the external drive on another computer?

Google MbrFix - download the program - burn it to a CD - boot from the CD (you might need to change the boot order in the BIOS to boot from the CD). I have never used this program and don't know the syntax for the command line interface. You will need to read the instructions.

fix the MBR on drive 2 your E drive (((( NOT on drive 0 which is your C drive))))
kegar89 6 Posts Tuesday October 21, 2008Registration date October 23, 2008 Last seen - Oct 23, 2008 at 01:24 PM
Yeah, I've tried it on other computers. It still doesn't work. I'll try this out.

EDIT: Just tried this FixMBR program, it doesn't work for me. I really don't know what to do. Anything else?
xpcman 19317 Posts Wednesday October 8, 2008Registration dateContributorStatus September 21, 2018 Last seen - Oct 23, 2008 at 02:08 PM
Thank you
Sorry i've run out of ideas.
kegar89 6 Posts Tuesday October 21, 2008Registration date October 23, 2008 Last seen - Oct 23, 2008 at 10:16 PM
Thank you
Maybe I'm doing something wrong?
jorisv 1 Posts Friday November 14, 2008Registration date November 15, 2008 Last seen - Nov 15, 2008 at 10:26 AM
Thank you
I have the same problem, did you already fix it ?
well, I used "safely remove" for the first time with my WesternDigital USB HD, as my Linux PC asked me to do that in windows that Ubuntu could mount the HD ("toy can mount this by.... Cmd commands, thanks yeah). So I did, copied some files, but now the USB port I was using (the only one in fornt) wont recognize USB HD. It work on other ports (on the back). I have removed all USB devices from device manager an let windows reinstall those, but no can do, the one front USB port, where I used "safely remove" won't recognize the WD USB HD. All usb sticks work, other USB HD's work, but this WD won't.

Thank you
me to I have the same problem I can see in my device menager but not icon in my computer
and in my laptop work only in py pc not
plase help
sorry for my english
Thank you
I have the same problem with my SimpleTech HD Cherry 320 GB External Hard Drive. My computer is no longer reading it. :( Any help?
Thank you
ohh man, you sure know how to help people :) thank you alot utaeladil!
Thank you
I followed utaeladil, advice about changing the drive letter and my comp finally found it, I just have one problem. I have about 100g worth of stuff on my external, but I can't get into it because it now wants me to format the drive. Is there anyway I can avoid doing this, and not lose any of my stuff?
Hmm Dharan, it sounds like the drive you are having trouble with may actually be experiencing a mechanical failure. Especially with it re-autorunning and taking much longer than it should. And if Windows sometimes wants to format the drive (that you know has data) then I would say thats another sign :( You may want to start getting some stuff backup up from that drive, incase it fails completely. If it's a newer drive with any warranty, you may want to start with checking with the manufacturer for a replacement. Good luck backing up the data, but it really sounds like that external drive may be on its last legs. :(
1 2 Next