Internal hard drive with all my data won't mount - Windows 7

Report
-
Posts
34
Registration date
Monday September 16, 2019
Status
Member
Last seen
October 27, 2020
-
Until a few days ago I was using Windows 7 on a 500 GB hard drive. All my data was on this drive. I then created a Linux partition (using Linux install to do this) and installed Linux. At that point I could boot up in Linux but not in Windows. I have no access to all my data. Subsequently, I installed a 1 terabyte solid state drive and installed both Windows and Linux on it without a problem. This time I used Windows to create the partition for Linux.
The 500 GB hard drive and the terabyte SSD drive are both installed and both recognized in BIOS and in Windows Disk Management and by the fdisk -l command in Linux. However Windows shows the disk as "unallocated space" but as a primary drive, type MBR. Linux shows it as drive 0 with no partitions. Is there a way to get this disk to mount so all its files can be seen?

1 reply

Posts
34
Registration date
Monday September 16, 2019
Status
Member
Last seen
October 27, 2020
5
The problem you're having is no error, it's expected behaviour. You've replaced the Windows bootloader 2 with another boot loader, probably GRUB. I'll assume you're using GRUB (you can check this by running [[ $(sudo dd if=/dev/sda bs=512 count=1 2>&1 | grep LILO) ]] && echo 'you use grub', or just ls /boot, if you see a GRUB folder then you're probably using grub). When you installed GRUB (read: when you installed Antergos) GRUB automatically looked for operating systems, and only found Arch/Antergos/whateverantergosis, and only generated boot entries for those. So reconfiguring GRUB won't help...

unless you use something like os-prober. With os-prober GRUB will detect Windows, and generate a boot entry for that too. I'm not sure what repos antergos uses, but there's a package called 'os-prober' in the arch community repo. Install that (sudo pacman -S os-prober) and regenerate your grub config (sudo grub-mkconfig -o /boot/grub/grub.cfg). You should then see some 'found Windows X on /dev/sdXY', and you should have the option to boot into Windows.

Subscribe To Our Newsletter!

The Best of CCM in Your Inbox

Subscribe To Our Newsletter!