Linksys Router wrt54g2

Closed
Report
-
 finallygotit -
Hello,
I have a Linksys router WRT54g2, the sleek black one, my problem is I cannot get the access restrictions to work, no matter what time I put in to deny access the laptop loses all internet access everytime, even if current time is 5pm I deny access for 10pm-11pm activate profile and bam laptop loses connection, as soon as I disable policy laptop works again, I am using the Mac address by the way. Also I noticed on the router status page the current time say "Not Available" could this be my issues? How do I get the time to show, I am on Comcast cable internet with a modem. thank you so much

FYI I had no luck with LInksys tech support

1 reply

Have you got it working yet?
I have messed with this for a week and finally it seems to be working, here is how:
Policy1 - Enable -Edit PC List (this only needs MAC Address of the wireless card of the machine to be restricted), then DENY (do not use allow for this).
I Selected Everyday, then Times. I denied access from 10:05 pm to 11:55 pm.
Save settings, then.......
Policy2 - Same again but this time I denied access from 12:05 am until 09:00 am.
Save settings, then.......
Policy3 - This one was necessary to Allow (use Allow button this time) access during daytime (10:00 am to 10:00 pm) but Block access to AOL, Myspace and a couple of others.
The difference with this policy was that I found I also had to add the MAC address of ALL machines on the network to this policy, otherwise it locks them out and only gives access to the listed machine during those hours.
Finally, Policy 4 - (Also an Allow policy) but only list machines you wish to allow fiull access to your network.
Set to Everyday and 24 hours.
This seems to override the other policies but only for the machines listed in this policy.
So far it seems to be working, so give it a go. If anyone has any better (simpler) solutions, let me know.
I will keep you posted if anything changes after testing it properly for a couple of weeks.
Did you get it to work? I am having same issues - can't get it to work and am ready to return it.
Policy 1: deny - all computers - listed all mac addresses for desktop, laptops, and I-touches
Policy 2: allow laptop #1 from 7 am to 10 pm - listed mac adress of laptop lan and wireless
Policy3: allow desktop from 5 am - 11:55 pm - listed mac address for lan
Policy 4: allow i-touch #1 from 7 am to 10:30 pm - listed mac address
Policy 5: allow i-touch #2 from 7 am to 11:55 pm - listed mac address
Policy 6: allow laptop #2 from 7 am to 11:55 pm - listed mac address for lan and wireless
> bk
Hi, Yes I did get it working eventually.
Having read dozens of other experiences with setting these up I cannot promise it will work for you but here goes:
My task was to disable my daughters PC from Internet Access from 10:00p.m. until 10:00 a.m. and also to permanently deny access to MySpace and AOL.
The key for me was in the word DISABLE. I assumed that as I was Disabling, the action was to Deny. Not so. You have to Allow as well. I'll explain.
Policy 1 (herpcpm) = Enable. herpcpm. Deny. Check Everyday. From 10:05pm To 11:55pm
Policy2 (herpcam) = Enable. herpcam. Deny. Check Everyday. From 12:05am to 9:00am
Policy3 (herpcblock) = Enable. herpcblock. Allow. Check Everyday. From 10:00am to 10:00pm
Then at the bottom of that screen add blocked services by entering URL and/or Keyword (I did both).
Policy4 (mypc) = Enable. mypc. Allow. Check Everyday. 24 Hours.
Edit list of PC's - Here you can use either MAC Address or IP Address. I used MAC.
Wireless MAC Filter = Enable and Permit only Listed PC's, then Edit MAC Filter List by adding the MAC Address of each machine you want to allow on your network.
Then dream up a metwork name only you would think of and disable the SSID broadcast. (You will need it to broadcast until your machines and network have found it for the first time, then Disable it).
I really hope this works for you, I know it is very frustrating, but know this, IT DOES WORK and you'll feel so good when you get there. Good luck.