Excel for mac opens all files on desktop [Solved/Closed]

emee - Aug 4, 2009 at 07:09 PM - Latest reply:  Dan
- Feb 14, 2013 at 01:52 PM
Hello,

Whenever I open any Excel file, Excel opens every file on my desktop as well (excel or not). I have to wait until the whole bunch load up, then close them all. Any thots?
See more 

10 replies

+26
Helpful
4
Here's an even simpler way to do it. I went into Documents and created a Folder (named "excel empty") and then went into Excel>Preferences>General and set the Open All Files In ... to this new empty folder. Seems to do the trick, as Excel now just opens to an empty worksheet. Can't image why Microsoft didn't just make this the default in the first place.
Was this answer helpful?  
Tapzee,

Thank you for an easy and quick fix to this really annoying problem.
this problem has been bugging me for years and your solution resolved it instantly...thank you.
this is the best tip dude....thanks a ton genius
or you can just delete any location in that field...it will not open anything on startup.
kaiyasit 30 Posts Sunday August 9, 2009Registration date April 20, 2010 Last seen - Aug 12, 2009 at 06:34 AM
+5
Helpful
Disable macro, and try to open again.
this may be help you......
+4
Helpful
The same thing happens to my mac! Everytime I open excel, it tries to open every file in my documents folder! Even files of different incompatible types. I can't get into "preferences for Excel" because of all the error messages. I've looked for Macros on the desktop and it does not find any.

HELP!
+4
Helpful
2
I called Mac support and they said its a Microsoft problem. I have Microsoft Office for Mac. Called Microsoft support and they walked me through a fix. They were great. Sorry I can't remember the fix. It involved a number of steps. But they didn't charge me anything for the phone consult.
Hi all,

This fix is probably too late for you guys, but may be useful for the next person. Same thing happened to me; excel was trying to open a few Gb of zip files!

If excel never manages to startup properly:
- force quit
- move all the files from the directory where excel is opening files to a temporary folder (delete everything from old directory making sure you don't loose any files!)
- open excel; it should be speedy now.
- go to excel>preferences>general, and delete the path in: 'At startup, open all files in:'
- move all your files from the temporary folder to their original folder (& overwrite the newly created 'Microsoft user data' folder)

I'm guessing this happened after I changed the 'preferred file location', but I can not remember whether the change in '...open all files in:' was an error on my part (very stupid one).

Hope that's useful

(MS Office 2008 mac v12.2.3)
hjuk > wuontherocks - Jan 15, 2010 at 10:39 AM
That was useful. Thank you. Could you say more about the User Data file deletion:
a. Location? I found one but it has loads in am am reluctant to delete it without knowing:-
b. What does it do?
c. Was this really created as part of the process you describe?