Kingston 8gb pendrive problem

yomi - Aug 25, 2009 at 10:32 AM
 Blocked Profile - Oct 29, 2010 at 06:12 PM
sir i bought a 8gb kingston pendrive 1 year ago and 3months after i bought it it got an external scratch but it was working fine but
2months ago i inserted the pendrive in one of my friends pc full of virus
later i cleaned the pendrive in my system from that day
my pendrive is not getting detected when i insert it for the first time
i should re insert it again and again
at 5th or 6th time it gets detected later on it works fine
i checked for boot sector errors and alll everything is fine but only it is not getting detected at the first time i insert

actually i gave the pendrive for replacement but due to the presence of scratch kingston is not replacing my pendrive
so guys plzzzzzz help me out

9 replies

sharpman Posts 1021 Registration date Saturday May 23, 2009 Status Contributor Last seen October 20, 2010 183
Aug 25, 2009 at 11:26 AM
have you tried the pendrive in all usb ports?
have you tried it in another pc?
iI have 8 gb kingston pen drive. i donot format it. it is write procact.
pls solve this problam
yomi123 Posts 2 Registration date Monday August 24, 2009 Status Member Last seen August 25, 2009
Aug 25, 2009 at 08:32 PM
yes i have tried in all usb ports and alll other pcs
sharpman Posts 1021 Registration date Saturday May 23, 2009 Status Contributor Last seen October 20, 2010 183
Aug 26, 2009 at 04:55 AM
it would indicate then that your pendrive has failed.
What happens is when you use a Virus gaurd to clean, it delets the ini file used to auto detect the drive.

What you must do is - after inserting the pen drive, click on my computer, then go to the Address bar drop down menu and click on Kingston drive. This will open Explorer dailogue box. From this you can select the document you need

Didn't find the answer you are looking for?

Ask a question
late, i know.
Jun 30, 2010 at 05:32 AM
go to control panel>admin tools> comp management > disk management, while ur usb plugged in. there, right click on the usb drive partition (use caution), delete the partition, then, repartition (is not the same as making a new partition, it means, make a new partition table entirely) choose mbr, and fat32. that should make it working.
i oso got this kind of problem...
my kingston pen drive is 16gb i buy this pen drive 10days it not working. files are not copying in the pendrive
Blocked Profile
Oct 29, 2010 at 08:56 AM


Return it to the shop where it was purchased as these devices usually have defects from manufacturer,

Blocked Profile
Oct 29, 2010 at 06:12 PM
Please get the problem solved thhrough the below instructions.