Kingston 0 bytes

MarkJan Posts 2 Registration date Tuesday February 23, 2010 Status Member Last seen February 23, 2010 - Feb 23, 2010 at 12:15 AM
 Zeus Raman - Feb 23, 2010 at 12:39 AM
hi,i have a problem with my Kingston 16GB usb flash drive,which is all the data I store on the flash drive cant be read!, I mean I put the data on the flash drive,safe remove it,then when I plug it in again I find all files are 0 bytes,although the same capacity of the files I put is taken,put I cant open the files,i tried formatting many times,but still didnt work,plz help guys..

The drive properties show:
Type: Removable Disk
File system: Unknown
Used space 0 bytes
Free space 0 bytes
Capacity 0 bytes

The Volumes tab shows:
Type: Removable
Status: No Media
Partition style: Not Applicable
Capacity: 0 MB
Unallocated space: 0 MB
Reserved space: 0 MB

1 reply

Hi there..
i worked as Tech support with Lexar. So, in my knowledge and experience, i've told you these guidances.. make a try..

Since you have formatted your pen drive, There are little chances for the data to be recovered, if you have formatted with data hidden in pen drive. But most of the time, this kind of problems will be solved, if you formatted your pen drive after proper data recovery.

To solve this problem, try using this steps(little hope to recover the data):

1. Try installing the pen drive in different USB slots of your computer.

2. Check your pen drive in different computer USB slots say in net cafe or browsing centre computers. It help you to find whether the problem is with the pen drive or with the USB slots of your PC.

3. Try different Pen drive in your PC USB slots. If still you face the same problem, then the problem may be with the USB slots of your PC.

4. . Find a computer with Windows98 and then download and install the driver for it (Windows98 requires a driver to read the drive). If you don't have W98, then go into XP. Control panel -> Computer Management -> Disk Management

5. Plug in the your Flash drive / Memory Stick -> The drive should appear, try and open it and get all your data off, if the drive doesn't appear there may still be hope

6. Format the drive as FAT32 under W98. Under XP right click under the flash drive letter. Ensure it is your flash drive, not your hard disk! You will lose all data when formatting.

7. If still you have the same issue, then the problem may be with you pen drive. Dont worry contact kingston tech support. Your problem is not a physical damage, so you will surely get replacement and they would help you in data recovery using their efficient data recovery softwares..