Can't open drive d:\ with double click

Solved/Closed
tol - Updated on Jul 10, 2017 at 12:44 PM
 Kazz - Jul 10, 2017 at 10:01 AM
Hello,

Please can somebady help me,
ine my computer I have 4 partitions: C: D: E: F:,
with partiton C is OK, but when I try to open partition D, E F, it shows message:

Choose the program you want to use to open this file:

File: D:


I'm waitting for any help
Related:

43 replies

JusK Posts 8 Registration date Monday July 21, 2008 Status Member Last seen January 23, 2009
Sep 18, 2008 at 05:04 AM
I had this problem too, then I made a new topic here and guys like Ravi and Manmeent helped me out her's what Ravi wrote (only instead of C write E and F):
go to command prompt and write this command

c:\> attrib -r -s -h autorun.inf
c:\> del autorun.inf
d:\> attrib -r -s -h autorun.inf
d:\> del autorun.inf
restart the pc
And here's the best and easyest suggestion of what Manmeet wrote(it worked for me!):

1Open Start >> Run and type regsvr32 /i shell32.dll
2. press ok
3. You will see a message DllRegisterServer and DllInstall in shell32.dll succeeded
4. that's it
SFE and tol PLEASE write how you solved this problem!
136
thank u guys(ravi,jusk).
0
thanks! it really worked. I searched everywhere for a solution and this one was very easy and it worked.
0
Thanks Jusk
e:>attrib -r -s -h autorun.inf
e:\> del autorun.inf and
restart the pc
its worked for me

Thanks
0
chandan > Sam
Oct 26, 2008 at 01:55 AM
this works fine..
you need to do this for each of the drive u r facing problem with
0
shahrukh Feroz > Sam
Dec 20, 2008 at 04:29 AM
hey sam you are the best ....... thanks a lot lot lot.......... muahhhhhhhhhh...
0
sorry for my english but there is a easy way to open a local disc
go to start and seach autorun.inf
delete them from the local disk
then go to my computer clik to local disk with the right buton of the mouse
go to propreties -->toolsand clik in--->check now
click in the automaticlly fix...... and start
and you'r done
20
guys snake is giving you the simplest solution and it works . thanks
0
unable to open D:\ drive by double clicking
13
This work for me:
d:\> attrib -r -s -h autorun.inf
d:\> del autorun.inf
Thanks JusK

to snake: your solution didnt work for me
9

Didn't find the answer you are looking for?

Ask a question
Big 10x from Bulgaria and please forgive me fof my bad english. Metod with attrib -r -h -s autorun.inf and del autorun.inf work perfectly and now Im very happy!!! Thank you!!!
6
this topic was very helpful .. thank you .. I hope u all enjoy ur life :D
5
Thanks guys!!
c:\> attrib -r -s -h autorun.inf
c:\> del autorun.inf
This worked for me.
For a note! - First I run this 2 commands for my C drive and restarting my windows it tidn't help. Then ran theese commands for C and D and restarted and it worked :))
Thanks peaople a lot !
5
Hello guys!!!
I tried ALL of your methods but no one worked at my pc! ComboFix did all the job. I recomend it! check this out here https://www.bleepingcomputer.com/combofix/how-to-use-combofix#use

it was the only way that helped at my pc. I tried many many times all other methods without resault...
4
yasser from egypt
Feb 1, 2009 at 08:27 AM
Thank you I used ComboFix.exe and it very good
0
verano333 Posts 2 Registration date Wednesday February 4, 2009 Status Member Last seen February 19, 2009
Feb 19, 2009 at 06:24 PM
Combofix worked for me...
4
hi All,i tried everything and nothing worked except combofix, he cleaned everything on my comp and thoese autorun.inf files even my bitdefender update wouldn't work and now it's all good :).i can log on my partitions just fine.thx a lot for tips all.cheers
2
the 'rename the drive' method is the simplest.thx~
2
Turn off AutoRun on all your drives.
http://forums.cnet.com/5208-6142_102-0.html?threadID=328308
2
arkantosa Posts 2 Registration date Monday May 18, 2009 Status Member Last seen May 19, 2009
May 19, 2009 at 06:04 AM
Hi all...
I've got a problem with your method:
c:/> attrib -r -s -h autorun.inf

It says:
'C:/' is not recognized as an internal or external command, operable program or batch file...

help!
2
Hiya,

For all of ya who say that when they open command prompt and type:-

c:\> attrib -r -s -h autorun.inf

and it says 'c:\' is not recognized as an internal or external command, operable program or batch file.

Type this first:-

cd\

It will open a new line starting with C:\> and then type the commands that freddy has said in his post,

and when ya have typed the command of the C: drive, type F:, G: or whatever the names of other drives you have in ur pc and again type the same commands listed by freddy.

Ya problem is solved enjoy!!!
2
I made this batch file which does all the drives I have then renamed each drive which was also necessary.
All drives now open normally. Note that each pause allowed you to see what happened.
Prior to all of this I installed recovery console and reset master boot record.
I also ran hijackthis_sfx.exe and mbam-setup.exe

CD\

c:
attrib -r -s -h autorun.inf
del autorun.inf
PAUSE

I:
attrib -r -s -h autorun.inf
del autorun.inf
PAUSE

L:
attrib -r -s -h autorun.inf
del autorun.inf
PAUSE

K:
attrib -r -s -h autorun.inf
del autorun.inf
PAUSE

M:
attrib -r -s -h autorun.inf
del autorun.inf

PAUSE
1
sorry for my English I had this same problem I can't open my drive and I used that it really work with
my pc

first you do that

go to run and type

c:\> attrib -r -s -h autorun.inf
c:\> del autorun.inf
d:\> attrib -r -s -h autorun.inf
d:\> del autorun.inf



and after that rename local drive anything like (softwereeeeeeeee)


thank you bro
1
Thanks roni.. Problem is solved by using same method mentioned by you and some other members also.
0
Thank you Thank you THANK YOU! Combofix is definitely the way to go! I was sitting here reading through all of these and realized that none of the methods above and on page 1 worked for me! I thought my computer was "extra" fudged up....but thank you Combofix! and whoever mentioned this first.
1
I resolved the similar problem by following just what you guys wrote here.

Thanks

Just don't forget to restart your computer to take this affect.
1
Hi guys... I've tried your method:
C:\> attrib -r -s -h autorun.inf
C:\> del autorun.inf
but something's wrong...
"'c:/' is not recognized as an internal or external command, operable program or batch file." and nothing changes after restarting pc...
what can you say about it?????
please help me...
1
Hi for me none of this solutions worked!! but I have another solutions thats working perfectly and easy.

go to windows instalation folder , open regedit and
Completely delete the following key:
HKEY_CURRENT_USER/Software/Microsoft/Windows/Current Version/Explorer/MountPoints2.
This last step should be repeated for all user accounts on your computer. You should then restart your computer and that's it.
1