Choose the program...message with all program

headhunter1324 - Mar 9, 2010 at 05:37 PM
 Dick - Mar 20, 2010 at 10:03 AM

Alright here's the deal...I was looking for free movies to watch online(foolish i know) and i went to one site (forget the name of it) and then one of those bogus virus scan things popped up. I didnt think much of it and figured if i just closed the window everything would be alright. Needless to say everything is not alright.

First my firewall got shut off and then little virus alerts were popping up in the bottom right on my screen. So myself not being greatly computer savvy decided the best thing would be to do a good ol System Restore. So I did that and then when i came back the only thing on my screen was the 'choose the program you want to use to open this file' box was there and File: rstrui was the program I was trying to open.

So i thought this was kind of weird but just figured that ill click cancel and I will go about my business. But then I thought it was weird when my AIM or my itunes didnt pop up upon loading. So I figured I would just click on them and load em up myself. And this is hen i knew something was really wrong.

Upon clicking on my itunes it says 'Application Not Found' and this also occurs with my Microsoft Word. I am not at all able to open my itunes but with Word I am able to go to my computer and open my previously saved word files and open the program that way.

Almost every one of my other desktop icons such as my AIM, gives me the aforementioned 'choose the program you want to use to open this file' message.

So this is where all of you lovely people come in. I would really appreciate if anyone has any ideas as to what is wrong with my computer and how I could go about fixing it.

I use Internet Explorer if that matters at all

Thanks in advance

2 responses

This happened to me after running Malware Bites to fix a variant of "security-tools" masquerading as avsoft antivirus and Total XP Security (fake virus program polymorphs). AVGFree wasn't able to find the virus, but superantispyware was able to find the avsoft regkey.

Try right mouse clicking and select "Run as" then click the dot for "the following user", enter "Administrator". This worked for me. If this doesn't work for you, the solution below most likely won't work, but you may have luck if you search for solutions to [HKEY_CLASSES_ROOT\exefile\shell\open\command].

The ability to run as administrator showed that the files needed to run the applications are still intact but the malware messed up the security permissions on the user account. I still haven't figured out which security permissions were changed. Permissions on rundll32.exe and and shell32.exe winlogon.exe appear ok.

To get around the problem, I used administrative tools under the administrator account to create a new user account with the ws02 built in permissions. That account works fine on the computer.

If someone knows how to fix the original account permissions, let me know. Good luck.
Mar 9, 2010 at 07:28 PM
More info i found for the problem im having...

I went to the control panel looking for anything I could possibly do to solve my problem so i tried to open the security center and the message: C:\WINDOWS\system32\rundll32.exe

Oh and when I try to download a virus scan from the internet the whole 'choose the program you want to use to open this file' thing happens...

I dont know if thatll help or not but hopefully it does.