Sony Vaio vpcf11s1e/b keyboard and touchpad

Closed
Rafa - Apr 8, 2010 at 02:20 PM
 stefffff - Jun 15, 2010 at 08:36 AM
Hi there.
Just bought my laptop 2 days ago.
Runned the instalation to get the Win7 Home Premium that came with it.
After, I installed TeamSpeak, and a couple of normal programs.
Today I was browsing the internet, when suddenly the touchpad froze. Didn't move more. The keyboard was still moving... so I tried to reset the computer so the problem went away. Instead of it, the keyboard also stoped working. Can't type anything on windows, but while windons is opening I can press F2, F8, F10 to acess the tools that the PC has (F2 Bios, F8 and F10 windows tools).
On the Bios my keyboard works.... no problem...
On any windows program, the "num pad" light gets off, and I can't type anything. Can't turn on neitheir the Num pad, Caps lock or Scroll lock, and no key works.....
As I had a password to enter windows... I tried to do a recovery.....
After the recovery.... STILL DOESN'T WORK...

Have a USB mouse that I can plug in and it works perfectly...

Please I need help....

4 replies

I have the same problem too on my sony vaio vgn-nw20zf. both the touchpad and keyboard are not working but the keyboard works on the startup and the mouse moves when it goes to auto repair windows 7 home premium user also. I only bought the laptop 3 days ago. If anyone can help I'd be very happy
0
I have the same problem on my VAIO VPC-F1190S
One day I logged into windows and the keyboard and track pad stopped responding, the keyboard works fine in the BIOS and when windows is starting. It also works in Ubuntu 9.10 but in Ubuntu 10.4 the keyboard works erratically for the login and then works fine but the track pad doesn t work either. In the windows device manager everything seems fine until I click on "Show hidden devices" and I see the Alps trackpad with a yellow exclamation mark and when I check the properties I have a error code 24.

If many of us are having this problem then maybe its bad hardware?
0
I have the same problem
0
okay i had the same problem... it's nothing with your keyboard... the problem is with your mouse! you are probably using a logitech or microsoft mouse... i used to have the same problem. i am using a vpcf11z1e with a microsoft mouse... after a windows 7 update the nightmare began... the mouse would stop working, the click actions were not recorded. i just unpluged the mouse from the usb and tried a different manufacturer... a4tech seems to work just fine... hope this helps
0