USB External HDD not accessible

dinu25 Posts 1 Registration date Sunday April 11, 2010 Status Member Last seen April 11, 2010 - Apr 11, 2010 at 03:52 AM
 dinu25 - Apr 17, 2010 at 04:01 AM
I have Maxtor 1TB External HDD. When I plug it into a laptop with Windows Xp Sp2 It is detected normally. But as soon as I double click on the drive icon windows pops up a message saying ' The file or directory is corrupted and unreadable'

When I checked in the Disk Management utility the drive is marked healthy but shows the drive space as unused. (I have atleast 750 GB of data in it).

So I ran the CHKDSK utility to check the disk.
It recognizes the partition as NTFS
Label as External
There are no errors and it shows 750 GB of used space.

But the disk still remains unreadable what should I do?

Please Help !



1 response

ok, fisrt of all, you need to figure out if it's the drive or the computer. does it work on another computer?

also, it could be your OS. you said have sp2 xp? you might have to upgrade to sp3, that's why mine was unreadable once. anyway, you might want to get sp3 because of the warrenty issue, sp2 is no longer supported by microsoft after july 13 2010.

ok so try it on another computer then post what happened.
I tried it on a desktop with same OS xp sp2 and on another one with vista home, but it wont work (again the same problem). what shud i do now?