Can't access data on my usb mass storage

snoopy - Oct 20, 2008 at 01:27 PM
 Srihari Raghavan R - May 24, 2013 at 06:45 AM

I have a 500GB Western Digital usb mass storage device with lots of data on it, and I have been using it without problems for several months. Now when I plug it in, the drive comes up in my computer as drive E as it usually does, but when I click it it asks me if I want to format it-when I click "no" I can't access the drive. If I format it again won't I lose all my files? The drive properties show 0kb for free space and 0kb for used space. What happened to the 300+ GB of files I stored on the drive? Is there another way to access the data on the drive? Thanks in advance for the help!

15 responses

Try to run "chckdsk x: /f", without the quotemarks and where x is the drive. I think you have to do it in Safe Mode MSdos [restart, press F8, go for "safe-mode with command prompt"], or when in XP mode: right-click on drive X, open Properties, Tools-tab, click "check now". You'll get message is not possible, only after restart: it will be scheduled at next reboot - just reboot.

If your disk is just too old, funked-up, or qurwalized and you just want to try to save the data, then please do use special software (or some PC-freak near u) - don't let XP try to fix it! For
.."CHKDSK X: /f"... Dat moet het zijn...
how to use it ? not so familiar pls help
Ridiculous, I did de chedisk and now, the folder it disapear
i love u it worked for me ,you kinda saved my life thanx
Hey there, I got the same problem as the person who start this forum's question.

but the problem is that
' The HDD is not mine, It's a friend of mine which I am not close with.'
So before I do anything, I want to confirm whether these steps are really reliable (not to question your capability, no offense)

and I really need the files in THAT HDD to be there, not deleted a single one =.=
am so scared that all the files will be lost!!!

'when in XP mode: right-click on drive X, open Properties, Tools-tab, click "check now". You'll get message is not possible' ---> this statement really showed up.
So does this mean I have to restart? but they did not give me any message to restart it, just asking me to format it!!

please help me!!
This is Kumar Pushkar from Bangalore India; even my seagate usb hard disk was not detecting error was something like all data has been corrupted cant detect even the segate disk manager was useless ,but friends there is one solution that worked for me just goto command prompt type chkdsk G:/f G:-is my usb drive just check it whether its useful for you.

best of luck
Thanks pal it worked
Srihari Raghavan R
May 24, 2013 at 06:45 AM
your solution
just goto command prompt type chkdsk G:/f G:-is my usb drive
worked for me. I did not loose a single file.
Thank you
xpcman Posts 19530 Registration date Wednesday October 8, 2008 Status Contributor Last seen June 15, 2019 1,832
Oct 21, 2008 at 03:15 AM
Do NOT format the disk - That will make it much much harder to recover the data.

I think you have a MBR (master boot record) problem - there is a fix.

Google MbrFix - download the program - burn it to a CD - boot from the CD (you might need to change the boot order in the BIOS to boot from the CD)

fix the MBR on drive 2 your E drive (((( NOT on drive 0 which is your C drive))))
wat do you mean by fix MBR on E drive?????
I have this same problem easily solved heres what to do this worked for me:

load up in safe mode (tap f8 on boot up) choose normal safe mode (rather than with command prompt or networking)

if asked load in as administrator

once loaded in locate problematic drive in my computer (double click on it and it should open)

next go back to my computer and right click on drive selecting properties

goto security tab and click on advanced to change permissions

then click on owner followed by edit

you should have a check box on the bottom of the screen to replace owner on subcontainers and folders tick it and click ok

all subfolders will be reset to you as owner and will be able to open it I believe this to be a problem with vista and on.

hope this helps someone :)
This just helped me! I was downloading all types of programs to scan my external USB drive's MBR and couldnt find anything wrong. Your post made me check the Security settings of the troubling partition and sure enough, Administrator was the only user with permissions on the drive. Thanks so much!
when I choose properties it doesn't appear to me security tab
im a noob so please dont throw any rotten tomatoes at my question:

could you be more specific when you say "load up"? do you mean on start up as in computer start up or when connecting the usb drive?

Didn't find the answer you are looking for?

Ask a question
power on your usb device, restart your pc ( while your usb is on), your windows will automatically boot to your usb device, your windows will fix it for you
Ive looked through all the answers and none of them worked for me, my 1tb HDD decided it wanted to be formated and I couldnt get any of my files off it.

Finally I found some freeware that is able to locate either deleted files or access this cuntish HDD.

Trust me on this one its works. Just go into options and tick the wee box that says scan undeleted files or something.

Hope that helps, because I found it torture trying to get my files back.
aotk Posts 2 Registration date Thursday December 31, 2009 Status Member Last seen January 1, 2010
Jan 1, 2010 at 04:20 AM
I have the same problem with my external hard drive (1tb) I followed the instructions and it seemed to work on the Partition wizard program, I can right click on the selected drive and see all my data is still on there. The only problem is when I try to open the drive via my computer, it does not open. "Location is not available - The file or directory is corrupted and unreadable" error message >.< any advice would be greatly appreciated.
Hi there!
I also have a problem with my external hard disk (500gb WD in a 3,5' case). It also fell off the table by accident.. Afterwards, I plugged it in my laptop and it never worked again.. What I mean? I plugged it in, for few seconds you can hear it "working" inside, then it stops and of course no disk drive appears on My Computer. In Computer Management -> Disk Management, I can see my basic disk (Disk 0), which is online, and another disk (Disk 1) which is unknown and not initialized (that it says!). I believe this is my external drive. I right click on this disk, no Initialize Disk option available, I can click either Properties and see that my disks' capacity, unallocated space and reserved space is 0MB and Partition Style: Not Applicable, or I can click the Offline option and get the message from virtual disk manager: Incorrect Function. I really don't know what to do!! One option is format the disk (but this is not an option for me since I have all my work from 7 years studies :-( ). I 've tried the partition wizard home edition but it can't find any external disk. It can only recognize my basic disk.. I REALLY HAVE NO IDEA... Please, please if anyone knows anything that might help me and not erase my data... say it... Thanks anyway!!
I'm having also a external disk. But a different situation. Its a disk from a laptop which I connected by a USB 2 adapter to my windows 7 pc. Windows 7 is detecting the disk, but I can't do something with it. I tried patition wizard, but it sees only my internal disk. I got also the message: virtual disk manager incorrect function
It's there but how can I get my data. Its important business related data.
please help
I am having the same as the above (elleboef ). Wondering if you found a solution?

In short,

1. USB attached harddrive.
2. The drive does not show up in my computer
3. Shows up in windows 7 computer management -> storage management as "unknown disk" but does not show up in partition wizard.

A little more ... while trying to find a solution windows 7 did ask if I wanted to rebuild the MBR but at that time I thought "no" then I read the posts and I can not get windows 7 to give me a pop up in the computer management - > storage management asking this question again.
bpm120 > bpm120
Mar 11, 2010 at 01:00 AM
My problem seems to have corrected itself after several reboots and plugging the drive into another usb port.

I think windows 7 fixed the master boot record on its own.

Unfortunately that does not help the others who have written in recently but perhaps it will help someone else in the future who reads this thread.
Well, technically speaking formatting won't make the data in your usb deleted permanently at least for the short term. But the best way to access your data before formatting is get the data back safely. You can use some data recovery software to do the job for you.

xpcman Posts 19530 Registration date Wednesday October 8, 2008 Status Contributor Last seen June 15, 2019 1,832
Jan 2, 2010 at 12:23 PM
I suspect the hard disk is broken beyond user repair. What the computer sees is the "USB hard disk adapter" hardware and not the hard drive. The software software is rather dumb and thinks if it can't read the data then it MUST format the drive. The hard disk DATA might be salvaged by a professional data recovery company. They can disassemble the drive in controlled conditions and pull the platter from the drive and place it in a identical drive housing. All this costs mega bucks (at least $500). If you want to use that option Google "Ontrack data recovery" .

Good Luck
I too am having the same problem. My Seagate 500GB HD was unplugged before ejecting and now comes up that it isn't formatted. I took it to the Geek Squad and of course they want $100 to restore it for me. I figured if they have some kind of program to be able to see the files on there and get them back for me, then there must be something out on the market (for way cheaper) that I can get to do it myself. Or that someone might have a trick up their sleeve for me to be able to access my files once again?
I have the same problem. I was able to recover most of my files using "PC Inspector File Recovery" (free,,23069-page,1-c,utilities/description.html (Some files were damaged, but they might have already been damaged when my hard drive crashed.) I'm surprised they didn't get higher ratings, but it worked for me!
you have to click the folder option on the toll bar Then in the right side your hd will show you YOu have to click tthat usb drive then only it will be open ..