IE gives can't display page msg since XP SP3 [Closed]

Report
-
 shaun -
es Hello,
Recently downloaded and installed SP3 for Windows XP. I'm on a dial up connection and although it is connected IE displays a Can't display page, check connection message. When I check the connection it seems to be looking for a DSL connection and I only have dial up. Doing a system restore to a point before the problem occurred fixes the problem, but simply uninstalling SP3 does not. I'm wondering if I'm missing a setting somewhere in IE.

I'm at the point where I have removed SP3 by using add and remove programs. I will do the sysem restore in the morning (it has been taking a long time) and see if that still works.

Does anyone know what is happening and how to fix it.

Thanks, Diana

2 replies

same problem on my other computer really wished i hadnt downloaded sp3
its doing my head in , i can sign in to msn but not view any web page ,

help!!!
shaun
3
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 2942 users have said thank you to us this month

Posts
19566
Registration date
Wednesday October 8, 2008
Status
Contributor
Last seen
June 15, 2019
1,692
Many people have had problems with SP3 - I would uninstall it and turn off auto updates. Have Windows alert you of new updates and bypass SP3 when you install them. Did it take all night to download SP3? With such a large and slow download you might have a corrupted copy of SP3. I believe there is nothing in SP3 that the average home user MUST have. Your PC will work just fine without it.

Subscribe To Our Newsletter!

The Best of CCM in Your Inbox

Subscribe To Our Newsletter!