WD MyBook StudioEd II won't mount on desktop! [Solved/Closed]

editionfive - Apr 19, 2010 at 11:18 AM - Latest reply:  Mark
- Nov 9, 2014 at 05:58 PM
Hi, I'm hoping someone could shed some light and let me know how to fix this problem. The My Book Studio Edition II that I've been using for 5 months (only) suddenly wouldn't mount on my PowerBook G4 (Mac OSX 10.4.11). I tried using Disk Utility and I could see the drive and the icon is dim. When I clicked "mount" it still wouldn't mount, the drive is still showing dim. The WD driver manager also showing the drive in good status and good condition on the menu bar and has the green light. The power light/LED status and activity lights seemed acting normal, it goes in & out when I tried to mount it. And I could hear the sound that normally when the drive is landed on the desktop. However, it's not there. I tried using different cable - Firewire 400, 800 and USB cable and it still wouldn't work.

I don't know if it's caused by the new Macbook Pro (latest Mac OSX Snow Leopard) I recently purchased. The whole problem started when I plugged the external MyBook HD to the new Macbook Pro to transfer some files, it was working, but then when I plugged it back to the Powerbook G4, it's just not showing. I then tried to plugged it again to the new Macbook pro, not showing either. I have the My Book HD configured in RAID 1 with no password at the moment.

I also bought another My Book Studio Edition II HD two weeks ago (don't know now if this is a good idea now!!). I'm using it with the Macbook Pro with Time Machine. At the moment seems to be working ok. But I'm not dare to plugged it in to the Powerbook G4, just in case it disappear on both laptops. I apologise for the long posting, but I think I've coveredd all the issues that I encountered. I hope the drive will come back so I can get back all the data (900MB) in it.

Thanks so much for your help in advance.
See more 

5 replies

Best answer
1
Thank you
1: remove both the power cable and FW cable
from the drive
2: wait for the drive to spin down
3: plug the power cable back in
4: press the power button; you should see the light
5: then connect the FW cable

Hard drive should mount. (It did when I tried the above!)

Thank you, Elvis 1

Something to say? Add comment

CCM has helped 1790 users this month

thank you! this worked great!
worked for me too, whew!
I tried but the drive does not mount. It shows up only in my MAC disk utilities app and the unmounted drive appears dim (I guess that means it is not mounted).
worked on the 3rd try!