System restore unsuccessful

takeadvice1221 Posts 18 Registration date Friday August 15, 2008 Status Member Last seen May 19, 2009 - Oct 27, 2008 at 08:44 AM
 Cheruba1 - Jun 4, 2009 at 02:30 PM
Hi, I tried to use system restore to undo some changes on my pc but it keeps telling me that the system restore was unsuccessful and to choose another system restore point any idea of what can I do please?

3 responses

I have this same problem! Yesterday I was doing disk cleanup (which I will NEVER do again) and somehow the cleanup dumped some essential feature of my Internet Explorer. Now when I try to install IE, it appears to install fine, but there is no shortcut on my desktop. It is essentially invisible. When I go to Add and Remove programs, Internet Explorer 8 is on the list, but no where to be found on my computer. SOOO--I am now trying to do system restore, but no matter how far back I go, it says that the system restore was unsuccessful and to fix another restore point. I tried every restore point there was, and not one of them went through! Somebody please help! :(
I have the same problem I have tried about 10 restore points and it always says unsucessful. I have so much stuff on my pc I don't want to loose but for some reason my printer will only print in text and in fine or photo only prints part of the page, Not the printer it works on the other pc. I havee been trying to get he computer to restore to a point where my printer workd OK. Helppppppppppp please someone
xpcman Posts 19530 Registration date Wednesday October 8, 2008 Status Contributor Last seen June 15, 2019 1,832
Oct 27, 2008 at 12:03 PM
Try a restore from an earlier date/time - that's about your only option. I know of no way to FIX a bad restore point.