USB modem doesn't get recognized

Closed
MK - Jun 13, 2010 at 07:38 AM
 preethi - Jun 16, 2010 at 02:07 AM
Hello,

I'm trying to run "Huawei Mobile Connect", a HSD based USB stick used for wireless broadband on XP 32-bit (SP3). This device seems to be a composite device as when I try running it on Vista (Home) it detects both the devices get detected and appear on different drives as :

E:\ (As Mass storage USB device)
F:\ (As Removable Disk)

When I try running it on XP, it only detects one device ('Mass stotrage USB) and shows only one drive i.e. it doesn't detect 'Removable Disk'. Also the icon for 'Portable Media Devices' under Control Panel incorrectly shows up. Some of the things I've checked:

1. usbstor.sys is present in drivers
2. usbstor.inf, usbstor.pnf present in C:\windows\inf
3. Registry entry: HKLM\SYSTEM\CurrentControlSet\Services\USBSTOR has start value '3'
4. No Unidentified device appears in Device Manager
5. USB Mass Storage Device shows up in Device Mgr when the USB stick is inserted.
6. All my other USB based Pen drives (mass storage), Camera, Mobile, External HDD drives are working normally.
7. Removable Storage and RPC services are running.
8. Tried uninstalling & re-installing the 'USB Mass Storage" device from the Device Manager.
9. Tried uninstalling & Re-installing the software/reboot etc.

Huawei device model number is EC168C

Similar posts suggest that its the USB modem which is somehow getting blocked and not showing up. Any help is much appreciated.

1 reply

Try the with driver software tat is available in web..........if u open tat removable/etc..drives for copy/paste it creates prob so ur adviced o use he driver s/w...........
-1