Acer Aspire G5900 Predator error [Solved/Closed]

helstrike - Sep 4, 2010 at 07:55 AM - Latest reply:  Sky/Cosmeo
- Nov 30, 2010 at 02:04 AM
Hello,

I recently bought a new desktop Acer Aspire G5900 Predator loaded with Windows 7 Home Premium 64 bit. However on the first run it could not load into windows. To be exact after I power on the PC the windows icon was loading, but after a while it just stuck at a black screen, I could still see my mouse moving but the entire screen is just black.

I have tried tapping the Alt+F10 and it went to the Acer recovery management menu, I selected the restore to factory default option, but the problem still persist. I could not enter safe mode too, it pops up a message like "Windows could not finish the installation in safe mode, it will finish the installation after restarting the system". However after I clicked ok, it still went into black screen after the windows icon.

Can anyone help me with this? I tried looking at the internet for solutions but to no avail. Could it be a faulty software or BIOS? If anyone could upload a copy of their recovery discs I would greatly appreciate it.


See more 

3 replies

netsa77 491 Posts Thursday July 17, 2008Registration date September 28, 2010 Last seen - Sep 5, 2010 at 02:06 AM
0
Thank you
Hi there,

As its new and recently bought its better you let the seller do needful for repairs,well try removing the battery and put it back with adapter connected after 2 minutes,if this works then you can also create your recovery cd,


Thanks
0
Thank you
Hi netsa77,

thx for the reply, I was thinking of sending it back for repairs however it's closed on weekend so I thought I might as well try something. As you mentioned removing the battery and put it back with adapter, well it is impossible as mine is a desktop and it doesn't have a battery pack. However I did try switching off the power supply then holding the power button on my desktop for 30sec so as to "hard reboot" my pc, before I switch back on the power.

Sadly that did not work out as planned and the problem still persists, I could not restore my desktop using acer eRecovery management, I tried the option restore to factory default and it does not work for me.

Is there other alternatives?
0
Thank you
I am unsure if this will work for you, but it did for me. If you have bought the entire package with the Acer LED monitor, then this method should work.
When you have reached the black screen(and you can see your cursor), move your hand to the power button of the monitor. To the left of it would be five buttons(It may not be easy to see depending on your lighting, thus the move your hand part). Press the nearest button and five icons should appear. Press the same button again(which is under the Input button) and your problem should be solved.

Note that you may have to do this everytime you start the computer.