Samsung g3 station would not autostart [Solved/Closed]

Registration date
Wednesday December 29, 2010
Last seen
December 29, 2010
 Gavinson -

I have the same problem. Mine is even worse because I have my backup files on it. It worked for sometime and stopped. It started flashing once you connect the usb when supposed to wait until activity happens. It has now since just wait but still cannot be recognized by OS win xp. It does not show under Explorer nor under computer management. Could someone please urgently assist since we are an NGO and without accessing those files, the organisation is dead
What happened to its autorun...

10 replies

I have recently bought the 1.5tb g3 and am running windows 7.

Have tried the above steps and swapped the cable, still no joy.

My computer and laptop both recognised the hard drive previously, as I had transferred 500gb of data onto the hard drive.

Any other suggestions please let me know before I return it.
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 2942 users have said thank you to us this month

I have the same problem
Registration date
Sunday June 6, 2010
Last seen
July 16, 2020


Try this 1

Follow the below instructions step by step and check if your computer is able to

detect the external drive.

1) There are some external drives that wont detect at first instance, all you have

to do is try different USB ports. Try connecting the external drive to the USB ports

that are available at the back of your CPU. If the problem still exists then follow

the next step

2) Connect your external drive --> Click on Start --> Run --> Type devmgmt.msc

and press Enter. "Device Manager" will be opened. If you notice any yellow mark

then right-click on it --> Select the option "Update" and follow the instructions.

3) If there is no yellow mark in the device manager then click on the white area in

that device manager window. Now click on "Action"--> Scan for hardware


4) If the problem still exists then click on the below link and follow the instructions

5) If the problem still exists then try to update the USB drivers.

6) Check the USB data cable also.

Good Luck
i had the same problem , I thin its because I dont safely remove it b4 shuting down ? , any way I hyst pull the power cord our from behind the harddrive and put it back in 10 secs later . hope it works for you
Registration date
Sunday May 15, 2011
Last seen
May 15, 2011

Sorry but I can't write well in inglish. I had the same problem. I had my all pictures in the hard disk and once day don't start it.

My solution was it:
1) Turn of all (computer and hard drive)
2) Turn on all.
3) start windows 7 in safe mode.
4) The OS (windows 7) began to repair all, includ the hard disk, so the hard disk began to read the information.
5) The OS restart.
6) Then, my Hard disk was detected for the computer.

Really I don't know what happend, but these steps worked.

I hope these steps helped for you.
Registration date
Sunday May 15, 2011
Last seen
May 15, 2011

Many thanks man that worked for me too. Using windows 8.1.
HELP! I've recently bought Samsung HX-DU020EC, and I'm having the same problem. When I plugged it in for the first time it worked good, but the next day it couldn't be recognized, so I tried changig the USB port on my laptop over and over it just didn't work. Then I shut down the comuter, turned it on while the HDD was plugged in, the result was the same. Then I tried device management and the drive wasn't recognized even there. So I tried most of the stuff written in the manual and finally it was recognized. Then I formated it thinking that the problem would be solved. But the problem is still here and now it doesn't matter how many times I plug in and plug out the usb, the power cord it can't be recognized.
Sorry !!
I am using Windows 7 Ultimate and has the same problem but cannot get past it.
Same problem, you have to disconnect all USB devices from your computer and then connect the Ext HD, you may have to connect HD 2x, Still working on a Perm. fix, will give u a headsup.
I found the solution in my Windows 8.1 computer as follows:

1. Go to desktop mode.
2. Open File Explorer.
3. Select "this PC".
4. Open the tab "Computer" (next to "file").
5. Click "Manage" and Computer Management will open.
6. Select "Services and Applications".
7. Double click on "Services" and a list of services will be shown.
8. Search for "Device Install Service". Right click and select "start".
9. Search for "Device Setup Maanger". Right click and select "start".
10. My computer suddenly found my external hard drive.
I found it the problem to be an issue of voltage drop over the usb cable. I just swapped a cable I had off my ps3 controller and it works a treat now. I also changed one of the usb ports I was using as well (this occasionally worked but only on a full unplug and restart of everything). So try get a good cable and try change to one of the "main usb" ports (i think they are also known as the primary usb ports. If you have 6 like I do, the two top ones are my primary ones apparently and they are delegated priority and power over the others says my mobo manual.
Now seriously, I have the same problem.
If it's not recognized by Windows,
I just wait for 5 minutes, then unplug and replug.
Mine will then be recognized.
This is likely a design flaw of these drives. Just keep unplugging and reseating it until it's seen by the OS. I've had mine do this since purchasing it a year ago. Often it's not seen the first time around. I suspect it doesn't spin up fast enough and the OS doesn't always recognise it at first. Unplug/reseat and you should come right before you do it for the 10th time lol.
try to clean the registry. it worked for me
How I do that?

Subscribe To Our Newsletter!

The Best of CCM in Your Inbox

Subscribe To Our Newsletter!